Choose the best route HDU - 2680 (多源点最短路)

ne day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

Input

There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home. 
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes . 
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations. 

Output

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

Sample Input

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

Sample Output

1
-1

题目大意:给你交通路线以及Kiki家能到达的车站,让你求出Kiki到达目的地的最短路,如果不能到达,就输出-1。

解题思路:对于给出的多个起点建立超级源点,让这个超级源点与每个起点具体为0,从这个超级源点跑spfa到终点即可。

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2680

/*
@Author: Top_Spirit
@Language: C++
*/
#include <bits/stdc++.h>
using namespace std ;
typedef unsigned long long ull ;
typedef long long ll ;
const int Maxn = 2e4 + 10 ;
const int INF = 0x3f3f3f3f ;
const ull seed = 133 ;
const double PI = acos(-1.0) ;
const ll MOD = 1e9 + 7 ;
int const MAXM = 505 * 505 ;

int dis[Maxn], vis[Maxn] ;
int head[Maxn], cnt ;
int n, m, s ;

struct Node {
    int to, w, Next ;
}e[Maxn];

void init(){
    memset(e, 0, sizeof(e)) ;
    memset(head, -1, sizeof(head)) ;
    memset(dis, 0, sizeof(dis)) ;
    cnt = 0 ;
}

void addEdge(int u, int v, int w){
    e[cnt].to = v ;
    e[cnt].w = w ;
    e[cnt].Next = head[u] ;
    head[u] = cnt++ ;
}

void Spfa(){
    for (int i = 0; i <= n; i++){
        vis[i] = 0 ;
        dis[i] = INF ;
    }
    queue < int > que ;
    que.push(0) ;
    vis[0] = 1 ;
    dis[0] = 0 ;
    while (!que.empty()){
        int now = que.front() ;
        que.pop() ;
        vis[now] = 0 ;
        for (int i = head[now]; i != -1; i = e[i].Next) {
            int v = e[i].to ;
            if (dis[v] > dis[now] + e[i].w) {
                dis[v] = dis[now] + e[i].w ;
                if (!vis[v]) {
                    vis[v] = 1 ;
                    que.push(v) ;
                }
            }
        }
    }

}

int main (){
    ios_base::sync_with_stdio(false) ;
    cin.tie(0) ;
    cout.tie(0) ;
    while (cin >> n >> m >> s){
        init() ;
        for (int i = 0; i < m; i++) {
            int u, v, w ;
            cin >> u >> v >> w ;
            addEdge(u, v, w) ;
        }
        int p ;
        cin >> p ;
        while (p--){
            int num ;
            cin >> num ;
            addEdge(0, num, 0) ;
        }
        Spfa() ;
        if (dis[s] == INF) cout << -1 << endl ;
        else cout << dis[s] << endl ;
    }
    return 0 ;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值