Choose the best route(HDU 2680)---多源单汇最短路问题

题目链接

题目描述

One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

输入格式

There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

输出格式

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

输入样例

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

输出样例

1
-1

分析

题目大意是有n个公交站和m条单向路线,kiki要从附近的多个车站选一个到底他同学家附近的车站s,要求花费最少。对于这种多起点单汇点的最短路,建立反图求汇点到各起点的最短距离之后找到最小值即可。
以下是分别用dijkstra、SPFA和SPFA(SLF优化)算法写成的源码。

源程序

Dijkstra算法

#include <bits/stdc++.h>
#define MAXN 1005
#define INF 0x3f3f3f3f
using namespace std;
struct Edge{	//链式前向星 
	int v,w,next;
	Edge(){};
	Edge(int _v,int _w,int _next){
		v=_v,w=_w,next=_next;
	};
	bool operator <(const Edge a)const{
		return w>a.w;
	}
}edge[MAXN*20];
int EdgeCount,head[MAXN];
int n,m,s,k,dis[MAXN],used[MAXN];
void addEdge(int u,int v,int w)	//链式前向星建图 
{
	edge[++EdgeCount]=Edge(v,w,head[u]);
	head[u]=EdgeCount;
}
void dijkstra()
{
	priority_queue<Edge> q;
	memset(dis,0x3f,sizeof(dis));
	memset(used,0,sizeof(used));
	dis[s]=0;
	q.push(Edge{s,0,0});
	while(!q.empty()){
		int u=q.top().v;q.pop();
		if(used[u])continue;
		used[u]=true;
		for(int i=head[u];i;i=edge[i].next){
			int v=edge[i].v,w=edge[i].w;
			if(dis[v]>dis[u]+w){
				dis[v]=dis[u]+w;
				q.push(Edge{v,dis[v],0});
			}
		}
	}
}
int main()
{
	while(~scanf("%d%d%d",&n,&m,&s)){
		memset(head,0,sizeof(head));	//初始化 
		EdgeCount=0;
		for(int i=1;i<=m;i++){
			int u,v,w;
			scanf("%d%d%d",&u,&v,&w);
			addEdge(v,u,w);	//反图 
		}
		dijkstra();
		scanf("%d",&k);	//起点车站个数 
		int ans=INF;
		for(int i=1;i<=k;i++){	//最小值 
			int tmp;
			scanf("%d",&tmp);
			ans=min(ans,dis[tmp]);
		}
		if(ans==INF)printf("-1\n");
		else printf("%d\n",ans);
	}
}

SPFA算法

#include <bits/stdc++.h>
#define MAXN 1005
#define INF 0x3f3f3f3f
using namespace std;
struct Edge{	//链式前向星 
	int v,w,next;
	Edge(){};
	Edge(int _v,int _w,int _next){
		v=_v,w=_w,next=_next;
	};
}edge[MAXN*20];
int EdgeCount,head[MAXN];
int n,m,s,k,dis[MAXN],ven[MAXN];
void addEdge(int u,int v,int w)	//链式前向星建图 
{
	edge[++EdgeCount]=Edge(v,w,head[u]);
	head[u]=EdgeCount;
}
void SPFA()
{
	queue<int> q;
	memset(dis,0x3f,sizeof(dis));
	memset(ven,0,sizeof(ven));
	dis[s]=0;
	ven[s]=1;
	q.push(s);
	while(!q.empty()){
		int u=q.front();q.pop();
		ven[u]=0;
		for(int i=head[u];i;i=edge[i].next){
			int v=edge[i].v,w=edge[i].w;
			if(dis[v]>dis[u]+w){
				dis[v]=dis[u]+w;
				if(!ven[v]){
					q.push(v);
					ven[v]=1;
				}
			}
		}
	}
}
int main()
{
	while(~scanf("%d%d%d",&n,&m,&s)){
		memset(head,0,sizeof(head));	//初始化 
		EdgeCount=0;
		for(int i=1;i<=m;i++){
			int u,v,w;
			scanf("%d%d%d",&u,&v,&w);
			addEdge(v,u,w);	//反图 
		}
		SPFA();
		scanf("%d",&k);	//起点车站个数 
		int ans=INF;
		for(int i=1;i<=k;i++){	//最小值 
			int tmp;
			scanf("%d",&tmp);
			ans=min(ans,dis[tmp]);
		}
		if(ans==INF)printf("-1\n");
		else printf("%d\n",ans);
	}
}

SPFA算法之SLF优化

#include <bits/stdc++.h>
#define MAXN 1005
#define INF 0x3f3f3f3f
using namespace std;
struct Edge{	//链式前向星 
	int v,w,next;
	Edge(){};
	Edge(int _v,int _w,int _next){
		v=_v,w=_w,next=_next;
	};
}edge[MAXN*20];
int EdgeCount,head[MAXN];
int n,m,s,k,dis[MAXN],ven[MAXN];
void addEdge(int u,int v,int w)	//链式前向星建图 
{
	edge[++EdgeCount]=Edge(v,w,head[u]);
	head[u]=EdgeCount;
}
void SPFA()
{
	deque<int> q;
	memset(dis,0x3f,sizeof(dis));
	memset(ven,0,sizeof(ven));
	dis[s]=0;
	ven[s]=1;
	q.push_back(s);
	int cnt;
	while(cnt=q.size()){
		int u=q.front();q.pop_front();
		ven[u]=0;
		for(int i=head[u];i;i=edge[i].next){
			int v=edge[i].v,w=edge[i].w;
			if(dis[v]>dis[u]+w){
				dis[v]=dis[u]+w;
				if(!ven[v]){
					if(cnt>1&&dis[v]>dis[q.front()])q.push_front(v);
					else q.push_back(v);
					ven[v]=1;
				}
			}
		}
	}
}
int main()
{
	while(~scanf("%d%d%d",&n,&m,&s)){
		memset(head,0,sizeof(head));	//初始化 
		EdgeCount=0;
		for(int i=1;i<=m;i++){
			int u,v,w;
			scanf("%d%d%d",&u,&v,&w);
			addEdge(v,u,w);	//反图 
		}
		SPFA();
		scanf("%d",&k);	//起点车站个数 
		int ans=INF;
		for(int i=1;i<=k;i++){	//最小值 
			int tmp;
			scanf("%d",&tmp);
			ans=min(ans,dis[tmp]);
		}
		if(ans==INF)printf("-1\n");
		else printf("%d\n",ans);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值