PAT 1078 Hashing (25 分)

1078 Hashing (25 分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.
Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.


Input Specification:
Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤ 1 0 4 10^4 104) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.


Output Specification:
For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -




解析

就是要求写一个除留余数法的hash函数,如果发生碰撞就使用平方探测法。
其中我感觉最难的是怎么判断一个数能不能insert进去。我没有很好的办法解决这个问题,
如果一个数能在数组长度Msize次探测出来,就OK,否则失败


#include<cstdio>
#include<vector>
#include<cmath>
using namespace std;
bool isprime(int num) {
	if (num <= 1)
		return false;
	int SQRT = (int)sqrt(num*1.0);
	for (int i = 2; i <= SQRT; i++)
		if (num % i == 0)
			return false;
	return true;
}
int nextprime(int num) {
	while (!isprime(num)) {
		num++;
	}
	return num;
}
int main()
{
	int Msize, N;
	scanf("%d %d", &Msize, &N);
	Msize = nextprime(Msize);
	vector<bool> have(Msize,false);
	int num;
	for (int i = 0; i < N; i++) {
		scanf("%d", &num);
		if (have[num%Msize] == false) {
			have[num%Msize] = true;
			printf("%d%c", num%Msize, i == N - 1 ? '\n' : ' ');
		}
		else {
			int probe = 1;
			while (probe <= Msize) {
				if (have[(num + probe*probe) % Msize] == true)
					probe++;
				else {
					have[(num + probe * probe) % Msize] = true;
					printf("%d%c", (num+probe*probe)%Msize, i == N - 1 ? '\n' : ' ');
					break;
				}
			}
			if(probe>Msize)
				printf("-%c", i == N - 1 ? '\n' : ' ');
		}
	}
}

/*
4 4
10 6 4 15
*/
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值