Finite Encyclopedia of Integer Sequences

题目描述

In Finite Encyclopedia of Integer Sequences (FEIS), all integer sequences of lengths between 1 and N (inclusive) consisting of integers between 1 and K (inclusive) are listed.
Let the total number of sequences listed in FEIS be X. Among those sequences, find the (X⁄2)-th (rounded up to the nearest integer) lexicographically smallest one.

Constraints
1≤N,K≤3×105
N and K are integers.

 

输入

Input is given from Standard Input in the following format:
K N

 

输出

Print the (X⁄2)-th (rounded up to the nearest integer) lexicographically smallest sequence listed in FEIS, with spaces in between, where X is the total number of sequences listed in FEIS.

 

样例输入

3 2

 

样例输出

2 1 

 

提示

There are 12 sequences listed in FEIS: (1),(1,1),(1,2),(1,3),(2),(2,1),(2,2),(2,3),(3),(3,1),(3,2),(3,3). The (12⁄2=6)-th lexicographically smallest one among them is (2,1).

 

题意:给你个k和一个n,现在要组成序列,k表示能用1-k的数字,n表示序列的长度可以是1-n。如:k=3,n=2,则可以组成的序列是(1),(1,1),(1,2),(1,3),(2),(2,1),(2,2),(2,3),(3),(3,1),(3,2),(3,3)共12个,设总数有X个,问你按照字典序排序第X/2个是那个序列。

分析:找呀找呀找规律,自己随便写了几组,巧了写的k全是偶数,就以为答案k/2、k、k、k.......。后来发现k为奇数情况下不是,当时懒得写了。以为推一推能推出来什么神奇的式子。构造的这种题还是找规律好。

1、k为偶数,序列为:k/2、k、k、k.......,共n个数。

2、k为奇数,序列为:(k+1)/2、(k+1)/2、(k+1)/2、(k+1)/2.......再往前推2/n个。

#include <iostream>
#include<bits/stdc++.h>
using namespace std;
int a[300050];
int main()
{
    int n,k,maxx;
    scanf("%d %d",&k,&n);
    maxx=n;
    if(k%2==0)
    {
        a[1]=k/2;
        for(int i=2;i<=n;i++)
        {
            a[i]=k;
        }
    }
    else
    {
        int it=n/2;
        for(int i=1;i<=n;i++)
        {
            a[i]=(k+1)/2;
        }
        while(it--)
        {
            if(a[maxx]==1)
            {
                a[maxx]--;
                maxx--;
            }
            else
            {
                a[maxx]--;
                while(maxx<n)
                {
                    maxx++;
                    a[maxx]=k;
                }
            }
        }
    }
    for(int i=1;i<=maxx-1;i++)
    {
        printf("%d ",a[i]);
    }
    printf("%d\n",a[maxx]);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值