POJ 3948 迷宫问题(广搜+路径记忆)

定义一个二维数组:
int maze[5][5] = {
0, 1, 0, 0, 0,
0, 1, 0, 1, 0,
0, 0, 0, 0, 0,
0, 1, 1, 1, 0,
0, 0, 0, 1, 0,
};
它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

搜索加上路径记忆一般就是开个结构体数组,其中有有个变量就是这个点的上一个点的标号。

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

int next[4][2]={{0,1},{1,0},{0,-1},{-1,0}};
typedef struct{
	int x, y;
	int pre;
}node;
node q[105], s[105];
int maze[5][5], book[5][5];
int head=1, tail=1, flag=0;
int main()
{
	for (int i=0; i<5; i++){
		for (int j=0; j<5; j++){
			scanf("%d", &maze[i][j]);
		}
	}
	q[tail].x=0;
	q[tail].y=0;
	q[tail].pre=-1;
	book[0][0]=1;
	tail++;
	while (head<tail){
		for (int k=0; k<4; k++){
			int tx=q[head].x+next[k][0];
			int ty=q[head].y+next[k][1];
			if (tx<0||tx>=5||ty<0||ty>=5)
				continue;
			if (book[tx][ty]==0 && maze[tx][ty]==0){
				book[tx][ty]=1;
				q[tail].x=tx;
				q[tail].y=ty;
				q[tail].pre=head;
				tail++;
			}
			if (tx==4 && ty==4){
				flag=1;
				break;
			}
		}
		if (flag==1)
			break;
		head++;
	}
	tail--;
	int t=1;
	while (q[tail].pre!=-1){
		s[t++]=q[tail];
		tail=q[tail].pre;
	}
	s[t].x=0;
	s[t].y=0;
	for (; t>=1; t--){
		printf("(%d, %d)\n", s[t].x, s[t].y);
	}
	return 0;
}

回溯版

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int nextt[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
struct node{
	int x, y;
	int pre;
};
struct node q[105];
int maze[5][5], book[5][5];

void getpath(int t)
{
	if (t==1){
		printf("(%d, %d)\n", q[t].x, q[t].y);
		return;
	}
	getpath(q[t].pre);
	printf("(%d, %d)\n", q[t].x, q[t].y);
}
int main()
{
	for (int i=0; i<5; i++)
		for (int j=0; j<5; j++)
			cin>>maze[i][j];
	
	int head=1, tail=1;
	q[tail].x=0;
	q[tail].y=0;
	q[tail].pre=-1;
	book[0][0]=1;
	tail++;
	int flag=0;
	while (head<tail){
		for (int k=0; k<4; k++){
			int tx=q[head].x+nextt[k][0];
			int ty=q[head].y+nextt[k][1];
			if (tx<0||tx>=5||ty<0||ty>=5)
				continue;
			if (maze[tx][ty]==0&&book[tx][ty]==0){
				book[tx][ty]=1;
				q[tail].x=tx;
				q[tail].y=ty;
				q[tail].pre=head;
				tail++;
			}
			if (tx==4 && ty==4){
				flag=1;
				break;
			}
		}
		if (flag==1)
			break;
		head++;
	}
	getpath(tail-1);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

H4ppyD0g

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值