PAT甲级刷题记录——1023 Have Fun with Numbers (20分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

思路

这题也很简单哈,直接用大整数的乘法进行计算,然后用is_permutation()来判断第二个数是不是第一个数的全排列就行了(这个函数也是C++11的内容,如果想用原始方法的话,请看《上机训练实战指南》)。

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn = 1010;
struct bign{
    int d[maxn];
    int len;
    bign(){
        memset(d, 0, sizeof(d));
        len = 0;
    }
};
bign change(string str){
    bign a;
    a.len = str.length();
    for(int i=str.length()-1, j=0;i>=0, j<str.length();i--, j++){
        a.d[j] = str[i]-'0';
    }
    return a;
}
bign multi(bign a, int b){
    bign c;
    int carry = 0;
    for(int i=0;i<a.len;i++){
        int temp = a.d[i]*b+carry;
        c.d[c.len++] = temp%10;
        carry = temp/10;
    }
    while(carry!=0){
        c.d[c.len++] = carry%10;
        carry /= 10;
    }
    return c;
}
int main(){
    string a, b;
    cin>>a;
    bign A = change(a);
    bign result = multi(A, 2);
    for(int i=result.len-1;i>=0;i--){
        b += result.d[i]+'0';
    }
    if(is_permutation(a.begin(), a.end(), b.begin())==true){
        cout<<"Yes\n"<<b;
    }
    else cout<<"No\n"<<b;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值