centos python升级3.x后pip3 install 出现pip is configured with locations that require TLS/SSL, however the

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/weixin_42357472/article/details/85562566

1.解決办法,首先安装 openssl-devel

sudo yum install openssl-devel

安装成功后,使用pip3 继续安装

#如果还是报错,那么进入步骤2

2.那么你需要 进入python 安装包 目录下重新编译并且安装python

cd Python-3.6.3

进入目录下,依次执行以下3条命令

./configure --with-ssl

make

sudo make install

执行完成后 pip3 就可以安装軟件了

#######################################
另转:centos 7 python2 装 3 共存:
https://blog.csdn.net/z646721826/article/details/82837331

####################################
升级 Python 之后,由于将默认的 python 指向了 python3,yum 不能正常使用,需要编辑 yum 的配置文件:

# vi /usr/bin/yum

# vi /usr/libexec/urlgrabber-ext-down

这两处文件都需要通过vi工具修改 ,将 #!/usr/bin/python 改为 #!/usr/bin/python2.7保存退出即可。

############################
另外安装python3后使用可能删除键backspace ,方向上下左右键异常,可以通过如下步骤解决
1.1.安装realine这个包

yum install -y readline-devel

2.cd 到您安装的python文件包目录下

a、使用make
b、make install 重新编译即可

############################################
CentOS编译安装软件过程中遇到zlib.h: No such file or directory

使用命令:yum install zlib-devel 解决问题

####################################
zipimport.ZipImportError: can’t decompress data; zlib not available 解决办法

1--下载python-pip的tar包
# wget https://pypi.python.org/packages/source/p/pip/pip-1.3.1.tar.gz --no-check-certificate 
 由于下载pip是基于https协议的,故需要在wget url后面加上--no-check-certificate,否则不能下载: 

2--安装pip:
#tar xzvf pip-1.3.1.tar.gz 
#cd pip-1.3.1 
#python setup.py install

3--安装:

 1.安装依赖zlib、zlib-devel
yum install zlib zlib
yum install zlib zlib-devel
 2.重新编译安装Python
执行:./configure
编辑Modules/Setup文件,找到下面这句去掉注释:#zlib zlibmodule.c -l$(prefix)/include-L$(exec_prefix)/lib-lz
重新编译安装:make & make install

#####################################
Python错误:No module named setuptools 解决方法

解决方法如下:

下载setuptools包

#  wget http://pypi.python.org/packages/source/s/setuptools/setuptools-0.6c11.tar.gz

解压setuptools包

# tar -xvf setuptools-0.6c11.tar.gz

# cd setuptools-0.6c11

编译setuptools

# python setup.py build

开始执行setuptools安装

# python setup.py install

centos7 安装scrapy出错Could not find a version that satisfies the requirement Twisted>=13.1.0

1错误原因,通过pip install 安装scrapy是报错Could not find a version that satisfies the requirement Twisted>=13.1.0 (from Scrapy) (from versions: ) 
No matching distribution found for Twisted>=13.1.0 (from Scrapy) 
原因是没有安装Twisted 
2.在这里需要安装twisted,可通过wget https://pypi.python.org/packages/source/T/Twisted/Twisted-15.2.1.tar.bz2 
获取,然后tar -xjvf Twisted-15.2.1.tar.bz2 进行解压 
注意在解压是可能会遇到tar (child): lbzip2: Cannot exec: No such file or directory 
tar (child): Error is not recoverable: exiting now 
tar: Child returned status 2 
tar: Error is not recoverable: exiting now的错误,这是因为你没有安装bzip2,通过 
yum -y install bzip2 命令安装一下就好了 
3.解压之后,cd Twisted-15.2.1到目录下,通过python3 setup.py install 指令进行安装 
4.最后直接进行pip install scrapy进行scrapy安装就行了

展开阅读全文

没有更多推荐了,返回首页