1009 Product of Polynomials (25分)
This time, you are supposed to find A×B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 3 3.6 2 6.0 1 1.6
#include<iostream>
using namespace std;
int main(){
int k1,k2,e;
double x,a[1001]={0},b[2020]={0};
cin>>k1;
for(int i=0;i<k1;i++){
scanf("%d %lf",&e,&x);
a[e]=x;
}
cin>>k2;
for(int i=0;i<k2;i++){
scanf("%d %lf",&e,&x);
for(int j=0;j<1001;j++){
b[j+e]+=(x*a[j]);
}
}
int cnt=0;
for(int i=0;i<2020;i++){
if(b[i]!=0.0) cnt++;
}
printf("%d",cnt);
for(int i=2019;i>=0;i--){
if(b[i]!=0)
printf(" %d %.1f",i,b[i]);
}
return 0;
}