PAT甲级——A1021 Deepest Root

题目

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes’ numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K componentswhere K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

Solution:

求树的最深度
首先求出是否为一个连通块,不是的话,那就直接输出ERROR
都使用DFS,求连通块和最深度

Code

#include <iostream>
#include <vector>
#include <set>
using namespace std;
int n, maxDeep = 0;
vector<vector<int>>v;
vector<bool>visit;
set<int>res;
void DFS(int u)
{
	visit[u] = true;
	for (int i = 0; i < v[u].size(); ++i)
		if (visit[v[u][i]] == false)
			DFS(v[u][i]);
}
int calComponents()
{
	int nums = 0;	
	for (int i = 0; i <= n; ++i)
		visit[i] = false;
	for (int i = 1; i <= n; ++i)
	{
		if (visit[i] == false)
		{
			DFS(i);
			++nums;
		}
	}
	return nums;
}
void DFS(int s,int u, int deep)
{
	visit[u] = true;
	if (deep > maxDeep)
	{
		maxDeep = deep;
		res.clear();
		res.insert(s);
	}
	else if (deep == maxDeep)
		res.insert(s);		
	for (int i = 0; i < v[u].size(); ++i)
		if (visit[v[u][i]] == false)
			DFS(s, v[u][i], deep + 1);
}
int main()
{
	cin >> n;
	v.resize(n + 1);
	for (int i = 1; i < n; ++i)
	{
		int a, b;
		cin >> a >> b;
		v[a].push_back(b);
		v[b].push_back(a);
	}
	visit.resize(n + 1);
	int nums = calComponents();
	if (nums > 1)
	{
		cout << "Error: " << nums << " components" << endl;
		return 0;
	}
	visit.resize(n + 1);
	for (int i = 1; i <= n; ++i)
	{		
		for (int i = 0; i <= n; ++i)
			visit[i] = false;
		DFS(i, i, 1);
	}
	for (auto ptr = res.begin(); ptr != res.end(); ++ptr)
		cout << *ptr << endl;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值