PAT甲级——A1004 Countion Leaves

题目

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0, the number of nodes in a tree, and M (<), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

Solution:
题目意思是:家族成员如同一棵树一样,让你输出每一层【每一代】的叶子节点个数【空节点个数】
先使用数组存储信息,然后记录每一层的空节点即可
可使用DFS和BFS
Code

#include <iostream>
#include <vector>
#include <queue>

using namespace std;

//给出一棵树,问每一层的叶子结点数量
//使用BFS或者DFS

vector<vector<int>>nodes(1001);
vector<int>depth(1001);
int maxDepth = -1;

void DFS(int index, int h)
{
    maxDepth = maxDepth > h ? maxDepth : h;
    if (nodes[index].size() == 0)//data[index].size() == 0)//即为叶子结点
        depth[h]++;//层数

    for (int i = 0; i < nodes[index].size(); ++i)
        DFS(nodes[index][i], h + 1);
}

void BFS( )
{
    queue<int>q;
    q.push(1);
    vector<int>level(1001, 0);//记录节点层数
    while (!q.empty())
    {
        int index = q.front();
        q.pop();
        maxDepth = maxDepth > level[index] ? maxDepth : level[index];//存储最大的层数
        if (nodes[index].size() == 0)//此节点为叶子节点
            depth[level[index]]++;//之所以要记录每个节点的层数,是因为,同一层有多个节点
        for (int i = 0; i < nodes[index].size(); ++i)
        {
            level[nodes[index][i]] = level[index] + 1;//孩子结点层数比父节点多一层
            q.push(nodes[index][i]);//将其孩子全部存入
        }
    }
}



int main()
{
    int N, M;//N为节点数目
    cin >> N >> M;        
    for (int i = 0; i < M; ++i)
    {
        int ID, k, a;
        cin >> ID >> k;
        for (int j = 0; j < k; ++j)
        {
            cin >> a;
            nodes[ID].push_back(a);//即为一个节点底下所挂的子节点
        }
    }

    //DFS(1,0);
    BFS( );
    cout << depth[0];
    for (int i = 1; i <= maxDepth; ++i)
        cout << " " << depth[i];
    cout << endl;

    return 0;

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值