【PAT甲】1002 A+B for Polynomials

题目

主体

This time, you are supposed to find A+B where A and B are two polynomials.

输入描述

Each input file contains one test case. Each case contains a pair of integers a and b where −10-6≤a,b≤10​6. The numbers are separated by a space.

输出描述

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

输入示例

2 1 2.4 0 3.2
2 2 1.5 1 0.5

输出示例

3 2 1.5 1 2.9 0 3.2

实现

思路

map数据结构,使用键值对

C++

#include <iostream>
#include <iomanip>
#include <map>
using namespace std;

int main(){
    map<int, float> coefMap;
    for (int i=0; i<2; i++){
        int k;
        cin >> k;
        for (int j=0; j<k; j++){
            int exp;
            float coef;
            cin >> exp >> coef;
            coefMap[exp] += coef;
            if (coefMap[exp]==0){
                coefMap.erase(exp);
            }
        }
    }
    cout << coefMap.size();
    for (auto it=coefMap.rbegin(); it!=coefMap.rend(); ++it){
        cout << " " << it->first << " "  << fixed << setprecision(1) << it->second;
    }
    cout << endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值