【PAT甲】1001 A+B Format

题目

主体

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

输入描述

Each input file contains one test case. Each case contains a pair of integers a and b where −10-6≤a,b≤10​6. The numbers are separated by a space.

输出描述

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

输入示例

-1000000 9

输出示例

-999,991

实现

思路

  • 输入数据格式
    • 根据给出的范围,直接使用int获取数据就可以
  • 输出数据
    • 核心问题在于,输出的数据需要格式化,即加上分隔用的逗号
    • 所以要分析添加逗号的情况,只要符合情况,就加上逗号即可

C++

#include<iostream>
#include<string>
using namespace std;

int main(){
    int a,b;
    cin >> a >> b;
    string c = to_string(a + b);
    for(unsigned int i=0;i<c.size();i++){
        cout<<c[i];
        if( (c.size()-i-1)%3==0 && c[i]!='-' && c.size()-i!=1) cout<<',';
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值