POJ - 3278 Catch That Cow (bfs)

POJ - 3278 Catch That Cow (bfs)

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题目大意:

给你个n和 k 从n走到k 最少需要走几步。
假设当前在x 下一步可以到x+1 ,x-1,2*x 三种情况。

解题思路:

最少多少步,很简单的就是bfs嘛,每一步都可以走三种状态,判断下这个状态能不能走

bool judge(int x){
 	if(x<0 || x>=1000000 || vis[x])  
        return false;  
    return true;  
}

把能走的地方加入队列就好。我这里重载了构造函数,这样是为了写着更方便。

	node(int X,int S):x(X),step(S){}

!!!!!!!!!!这个题有个坑点,我至今不知道为什么。数组开成1e5 就runtime error 开1e6就可以过。!!!!!!!!!!我RE了好多次。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#define ll long long
using namespace std;
const int maxn = 1e6+10;
int n,k;
int vis[maxn];
struct node {
	int x;
	int step;
	node(){}
	node(int X,int S):x(X),step(S){}
};
void init(){
	memset(vis,0,sizeof(vis));
}
bool judge(int x){
 	if(x<0 || x>=1000000 || vis[x])  
        return false;  
    return true;  
}
int bfs(int s,int e){
	queue<node> q;
	q.push(node(s,0));
	vis[s] = 1;
	while(q.size()){
		node now = q.front();
		q.pop();
		int xx = now.x;
		if(xx==e){
			return now.step;
		}
		int tx;
		tx=xx+1;
		if(judge(tx)){
			vis[tx]=1;
			int num=now.step+1;
			q.push(node(xx+1,num)); 
		}
		tx=xx-1;
		if(judge(tx)){
			vis[xx-1]=1;
			int num=now.step+1;
			q.push(node(xx-1,num));
		} 
		tx=xx*2;
		if(judge(tx)){
			vis[2*xx]=1;
			int num=now.step+1;
			q.push(node(2*xx,num));
		}
	} 
	return -1;
}
int main()
{
	while(cin>>n>>k){
		init();
		int ans = bfs(n,k);
		cout<<ans<<endl;
	}
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值