POJ - 1459 Power Network(网络流)

POJ - 1459 Power Network(网络流)

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.
Input
There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.
Output
For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.
Sample Input
2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
(0)5 (1)2 (3)2 (4)1 (5)4
Sample Output
15
6
Hint
The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

题目大意:

n个点,m条边,np个发电站(只发电不消耗),nc个消耗者(只消耗不发电),剩下的点是中转点(不发电,不消耗)。
第一行 n np nc m
接下来是m行 每行表示一个边 (u,v) w 单向边
接下来是np行,每行表示一个发电站(u)w 表示u的发电量为w
接下来是nc行,每行表示一个消耗点(u)w 表示u的消耗电量为w

解题思路:

m条边建图(每个点都+1,因为给的点是从0开始,我们让他从1开始)。然后设超级源点0,连发电站,流量为发电量,每个消耗点连汇点n+1,流量是耗电量,然后跑 0 -n+1的最大流就好了。

注意输入的时候 要在前面加个空格不然读不进去。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
#define inf 0x3f3f3f3f
using namespace std;
const int maxn = 1e5+10;
int n,m;//n是点数,m是边数
int np,nc;
int sp,tp;//原点 汇点
struct node{
	int to;
	int w;
	int next;
}side[maxn*10];
int head[maxn],cnt = 0;
int deep[maxn];//每个点的层数
int cur[maxn];//当前弧优化
void init(){
	memset(head,-1,sizeof(head));
	cnt = 0;
}
void add(int x,int y,int w){
	side[cnt].to = y;
	side[cnt].w = w;
	side[cnt].next = head[x];
	head[x] = cnt++;
}
//分层
bool bfs(){
	memset(deep,-1,sizeof(deep));
	queue<int> q;
	q.push(sp);//放入原点
	deep[sp] = 0;
	while(q.size()){
		int now = q.front();
		q.pop();
		for(int i=head[now];i!=-1;i=side[i].next){
			int to = side[i].to;
			if(deep[to]==-1&&side[i].w>0){
				deep[to] = deep[now]+1;
				q.push(to);
				if(to == tp) break;
			}
		}
	}
//	if(deep[tp]==-1) return false;
//	else return true;
	return deep[tp]!=-1;
}
//找增广路 u是当前节点 cap是当前的流量
int dfs(int u,int cap){
	if(u==tp||cap==0) return cap;
	int res = 0;
	int f;
	for(int &i=cur[u];i!=-1;i=side[i].next){
		int to = side[i].to;
		//多路增广优化
		if(deep[to] ==deep[u]+1&&(f=dfs(to,min(cap-res,side[i].w)))>0){
			side[i].w -=f;
			side[i^1].w += f;
			res += f;
			if(res == cap) return cap;
		}
	}
	if(!res) deep[u] = -1;//这个点废了,炸点优化
	return res;
}
int Dinic(){
	int ans = 0;
	while(bfs()){
		for(int i=0;i<=tp;i++) cur[i] =head[i];
		ans += dfs(sp,inf);
	}
	return ans;
}

int main(){
	while(~scanf("%d%d%d%d",&n,&np,&nc,&m)){
		init();
		int u,v,w;
		sp = 0;
		tp = n+1;
		while(m--){
			
			scanf(" (%d,%d)%d",&u,&v,&w);
			u++,v++;
		//	cout<<"add "<<u<<" "<<v<<" "<<w<<endl;
			add(u,v,w);
			add(v,u,0);
		}
		while(np--){
			scanf(" (%d)%d",&u,&w);
			add(0,u+1,w);
			add(u+1,0,0);
		//	cout<<"add "<<u<<" "<<v<<" "<<w<<endl;
		}
		while(nc--){
			scanf(" (%d)%d",&u,&w);
			add(u+1,n+1,w);
			add(n+1,u+1,0);
		}
		printf("%d\n",Dinic());
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值