HDU - 2841 Visible Trees (思维 + 容斥原理)

10 篇文章 0 订阅
5 篇文章 0 订阅

HDU - 2841 Visible Trees (思维 + 容斥原理)

There are many trees forming a m * n grid, the grid starts from (1,1). Farmer Sherlock is standing at (0,0) point. He wonders how many trees he can see.

If two trees and Sherlock are in one line, Farmer Sherlock can only see the tree nearest to him.
Input
The first line contains one integer t, represents the number of test cases. Then there are multiple test cases. For each test case there is one line containing two integers m and n(1 ≤ m, n ≤ 100000)
Output
For each test case output one line represents the number of trees Farmer Sherlock can see.
Sample Input
2
1 1
2 3
Sample Output
1
5

题目大意:

给你n,m。在平面直角坐标系上有n*m,个点,左下角是(1,1)右上角是(n,m).
问 从(0,0)看,最多可以看到多少点?(比如(1,1) (2,2) (0,0)在一条线上,从原点就只能够看到(1,1)一个点)

解题思路:

画画图就会发现 只要gcd(x,y)==1的就能看到。只要发现了这个问题就简单了
至于为什么 gcd(x,y)==1就能看到呢? 我们想啊 如果它不等于1 肯定能x y同时除以gcd(x,y),得到x’ y’且gcd(x’,y’)==1 所以这个斜率一定出现过了,那就会被遮挡。

接下来的问题就是 在这个n*m这个矩阵中有多少对点(x,y)满足gcd(x,y) ==1
那么我们遍历1-n 看有1-m中有多少和i互质的,把结果累加就是我们要的答案。

	for(int i=1;i<=n;i++){
			ans += fun(i,m);
		}

如何求 1-m中与i互素的数的个数的 看https://blog.csdn.net/weixin_43179892/article/details/98237974这篇博客。

AC代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm> 
#define ll long long 
using namespace std;
const int maxn = 1e5+10;
int p[maxn];
int num = 0;
ll gcd(ll a,ll b){
	if(b==0) return a;
	else return gcd(b,a%b);
} 
void pr(ll k){//求k的质因子
	num = 0;
	for(int i=2;i*i<=k;i++){
		if(k%i==0){
			p[num++] = i;
			while(k%i==0) k/=i;
		}
	}
	if(k>1) p[num++] = k;
}
ll solve(ll n){//求1-n中不和k互质的数的个数
	ll ans = 0;
	for(ll i = 1;i<(ll)1<<num;i++){
		int ant = 0;//奇数个质因数加偶数个减
		ll t = 1;
		for(int j=0;j<num;j++){
			if(((ll)1<<j)&i){
				t*=p[j];
				ant++;
			}
		}
		if(ant & 1) ans += n/t;
		else ans -= n/t;
	}
	return ans;
}
ll fun(ll x,ll y){
	pr(x);
	ll no = solve(y);
	return y-no;
}
int main(){
	int t;
	int cas = 1;
	scanf("%d",&t);
	ll n,m;
	while(t--){
		ll ans = 0;
		scanf("%lld%lld",&n,&m);
		for(int i=1;i<=n;i++){
			ans += fun(i,m);
		}
		printf("%lld\n",ans);
	}

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值