PAT甲级1065答案(使用C语言)

题目描述

Given three integers A, B and C in [−2​^63​​ , 2^​63​​ ], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

题目要求总结

题目的要求很简单,输入n个case,每个case包含ABC三个数,判断A+B是否大于C,大则输出true,否则输出false

这里要考虑整数溢出的情况:
1.当两个整数>0且相加<0时,这时候说明溢出,则两个数的和一定大于第三个数
2.当两个整数<0且相加>=0时,这时候说明溢出,则两个数的和一定小于第三个数

这里参考判断整数溢出的一些资料
C语言整数相加溢出判断的三种方法
C语言判断整数溢出

总结一下:正数溢出会变成负数,负数溢出会变成正数
在这里插入图片描述
假设整数的范围为-32768 - 32767,则当输入整数为32768时,输出则变成-32768,(即上图圆形展示的关系),当输入的数为-32770时,则输出32766

另外因为负数的范围通常要比整数多1,所以如果两个小于0的整数相加时,可能出现等于0的情况, 例如-32767和-32769(因为溢出,所以为32767),相加即为0

AC代码

#include<stdio.h>
#include<limits.h>
int n;
bool flag[100000];

int main(){
	scanf("%d", &n);
	
	for(int i = 0; i < n; i++){
		long long a, b, c;
		scanf("%lld%lld%lld", &a, &b, &c);
		if(a > 0 && b > 0 && a + b <= 0){
			flag[i] = true;
		}
		else if(a < 0 && b < 0 && a + b >= 0){ //这里有等于0的情况要记得加入
			flag[i] = false;
		}
		else flag[i] = a + b > c;
		printf("Case #%d: %s\n", i+1, flag[i]?"true":"false");
	} 
	/*
	for(int j = 0; j < n; j++){
		printf("Case #%d:%s\n", j+1, flag[j]?"true":"false");
	}*/
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值