PAT甲 1050 String Subtraction (20 分)

Given two strings S1​ and S2​, S=S1​−S2​ is defined to be the remaining string after taking all the characters in S2​ from S1​. Your task is simply to calculate S1​−S2​ for any given strings. However, it might not be that simple to do it fast.

Input Specification:
Each input file contains one test case. Each case consists of two lines which gives S1​ and S2​, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:
For each test case, print S1​−S2​ in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

1、参考了网上的资料PAT中不能使用gets,改用cin.getline
2、遇到第三个数据显示格式错误,问题在第二字符串中可能含有空格,要注意把S1中的空格也删除。
3、使用set的find函数,在集合里查找是否存在

#include<cstdio>
#include<iostream>
#include<set>
#include<cstring>
using namespace std;

int main() {
	char s1[10001];
	char s2[10001];
	bool f[10001],f1=false;
	set<char> s;
	cin.getline(s1,10001);
	cin.getline(s2,10001);
	for (int i = 0; i < strlen(s2); i++) 
		s.insert(s2[i]);
	
	for (int i = 0; i < strlen(s1); i++) {
		if (*s.find(s1[i])==s1[i]) f[i] = false;
		else f[i] = true;
	}
	for (int i = 0; i < strlen(s1); i++) 
		if (f[i]) cout << s1[i];
	
	return 0;
}

欢迎指导和交流!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值