Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.
Input
Each line will contain one integer n(0 < n < 1000000).
Output
Output the LPF(n).
Sample Input
1
2
3
4
5
Sample Output
0
1
2
1
3
题意:找出最大的素因数是什么位置,素数2的位置为1,素数3为2,素数5为3等,特别是LPF(1)=0;
思路:先素数线性筛打表并开个数组记录每个素数的位置,如果输入的是素数直接输出对应的位置,如果是合数,先分解质因数后找出最大的素因子并输出它的位置。
AC代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int pem[1000100],p[1000100];
int n,tot=0;
int N=1000010;
int v[1000100];
void pan()
{
for(int i=2;i<N;i++)
pem[i]=1;
for(int i=2;i<N;i++)
{
if(pem[i])
{
p[tot++]=i;
v[i]=tot;
}
for(int j=0;j<tot&&i*p[j]<N;j++)
{
pem[i*p[j]]=0;
if(i%p[j]==0)break;
}
}
}
int phi(int x)
{
int ans=0;
for(int i = 2; i*i<= x; i++){
if(x % i == 0){
{
ans=i;
}
while(x % i == 0) x /= i;
}
}
if(x > 1)
{
//ans = ans / x * (x-1);
ans=x;
}
return ans;
}
int main()
{
pan();
while(scanf("%d",&n)!=EOF)
{
int t;
t=phi(n);
printf("%d\n",v[t]);
}
}
找最大质因数的时候一开始用的开根号的暴力,但是超时,这里用的解欧拉函数时的质数分解。