PAT甲级1044 Shopping in Mars//二分法求子序列和

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:
Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).
Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.
If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤105​​ ), the total number of diamonds on the chain, and M (≤108​​ ), the amount that the customer has to pay. Then the next line contains N positive numbers D1​​ ⋯DN (Di​​ ≤103​​ for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.
If there is no solution, output i-j for pairs of i ≤ j such that Di + … + Dj >M with (Di + … + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.
It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

思路

这题我不太会做(除了套两个循环的暴力做法,但是肯定会超时)参考了算法笔记的做法,这里摘录书上的思路。
令一个sum[i]表示a[1]到a[i]的和,比如sum[3]表示a[1]累加到a[3],sum[5]表示a[1]累加到a[5]。因为a[i]肯定是正数,所以sum[i]严格递增。这样做的就能很方便的求连续子序列a[i]到a[j]的和,因为可以直接用sum[j] - sum[i - 1]得到。
因为sum严格递增,所以可以想到二分法来处理,假设需要在序列a[1] ~ a[n]中寻找和为S的子序列,就可以枚举左端点i,然后在sum数组[i, n]范围内寻找值为sum[i - 1] + S的元素(因为sum[j] - sum[i - 1] = S)是否存在:如果存在,则把对应的下标作为右端点j;不存在,找到第一个使和超过S的右端点j。
因为题目要输出所有方案,所以对序列遍历两次,第一次遍历求出大于等于S的最接近S的和值nearS;第二次遍历找到那些值恰好为nearS的方案并输出。

#include <iostream>
#include <cstdlib>
#include <climits>
using namespace std;
int n, m, nearm = INT_MAX;
int sum[100005];
int upperbound(int L, int R, int x);
int main()
{
	cin >> n >> m;
	sum[0] = 0;
	for (int i = 1; i <= n; i++)
	{
		cin >> sum[i];
		sum[i] += sum[i - 1];
	}
	for (int i = 1; i <= n; i++)
	{
		int j = upperbound(i, n + 1, sum[i - 1] + m);
		if (sum[j - 1] - sum[i - 1] == m) //不是sum[j] - sum[i - 1],因为j是第一个大于X的位置
		{
			nearm = m;
			break;
		}else if (j <= n && sum[j] - sum[i - 1] < nearm) //是否比当前nearm还小
			nearm = sum[j] - sum[i - 1];
	}
	for (int i = 1; i <= n; i++)
	{
		int j = upperbound(i, n + 1, sum[i - 1] + nearm); //找能使和为最小的nearm的右端点
		if (sum[j - 1] - sum[i - 1] == nearm)
			cout << i << '-' << j - 1 << endl;
	}
	system("pause");
	return 0;
}
int upperbound(int L, int R, int x)
//返回[L, R)内第一个大于X的位置,注意是大于,不是大于等于
{
	int left = L, right = R, mid;
	while (left < right)
	{
		mid = (left + right) / 2;
		if (sum[mid] > x)
			right = mid;
		else
			left = mid + 1;
	}
	return left;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值