PAT甲级1064 Complete Binary Search Tree//完全二叉树和二叉排序树结合

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.
Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

题目大意

要求构造一棵二叉排序树,同时还得是完全二叉树

思路

这题目比较考验对完全二叉树和二叉排序树的了解。这题考察了以下两点:

  1. 二叉排序树的中序遍历序列是递增的
  2. 如果使用数组来存放完全二叉树,那么对完全二叉树当中的任何一个结点(编号x,根结点标号为1),其左孩子结点编号一定是2x,有孩子结点编号一定是2x+1

知道这两点后如何解题就比较明朗了。开一个数组in(编号1~N)用来存放完全二叉树的n个结点,然后将题目所给的所有结点进行递增排序,再对in数组表示的二叉树进行中序遍历,遍历的同时将数字由小到大放进去。最后要求输出完全二叉树的层序遍历,然而完全二叉树的层序遍历就是这个in数组。

#include <iostream>
#include <vector>
#include <cstdlib>
#include <algorithm>
using namespace std;
int in[1001], index = 0, N;
vector<int> tree;
void inOrder(int);
int main()
{
	cin >> N;
	for (int i = 0; i < N; i++)
	{
		int node;
		cin >> node;
		tree.push_back(node);
	}
	sort(tree.begin(), tree.end());
	inOrder(1);
	for (int i = 1; i <= N; i++)
	{
		if (i != 1)
			cout << " ";
		cout << in[i];
	}
	system("pause");
	return 0;
}
void inOrder(int root)
{
	if (root > N)
		return;
	inOrder(2 * root);
	in[root] = tree[index++];
	inOrder(2 * root + 1);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值