PAT甲级1147 Heaps//判断大顶堆小顶堆

该博客探讨了计算机科学中的堆数据结构,特别是二叉堆的概念,包括最大堆和最小堆的定义。通过完全二叉树的水平遍历序列判断其是否为合法的堆,并给出相应的后序遍历序列。文章提供了输入输出规范,包括测试用例,以及如何通过先序遍历序列判断堆类型和生成后序遍历序列的算法实现。
摘要由CSDN通过智能技术生成

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))
Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

思路

写过*PAT甲级1155 Heap Paths//手动模拟反向先序序列//判断大顶堆小顶堆之后这题就很简单了。通过完全二叉树的水平序列判断是大顶堆还是小顶堆或者不是堆,然后再求后序序列

#include <iostream>
#include <cstdlib>
#include <vector>
#include <algorithm>
using namespace std;
int M, N;
vector<int> post;
void postOrder(vector<int> &, int);
int judge(vector<int> &);
void print();
int main()
{
	cin >> M >> N;
	vector<int> level(N + 1);
	for (int i = 0; i < M; i++)
	{
		for (int j = 1; j <= N; j++)
			cin >> level[j];
		switch (judge(level))
		{
		case 1:
			cout << "Max Heap" << endl;
			break;
		case 2:
			cout << "Min Heap" << endl;
			break;
		case 3:
			cout << "Not Heap" << endl;
			break;
		}
		postOrder(level, 1);
		print();
	}
	system("pause");
	return 0;
}
int judge(vector<int> &vec)
{
	bool isMax = true, isMin = true;
	for (int i = 2; i < vec.size(); i++)
	{
		if (vec[i / 2] > vec[i])
			isMin = false;
		if (vec[i / 2] < vec[i])
			isMax = false;
	}
	if (isMax)
		return 1;
	else if (isMin)
		return 2;
	else
		return 3;
}
void postOrder(vector<int> &vec, int root)
{
	if (root > N)
		return;
	postOrder(vec, root * 2);
	postOrder(vec, root * 2 + 1);
	post.push_back(vec[root]);
}
void print()
{
	for (int i = 0; i < post.size(); i++)
	{
		if (i != 0)
			cout << " ";
		cout << post[i];
	}
	cout << endl;
	post.clear();
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值