Largest Rectangle in a Histogram【单调栈模板】

21 篇文章 1 订阅

Largest Rectangle in a Histogram

题目链接(点击)来源poj 2559


    A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: Description


    Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

Hint

Huge input, scanf is recommended.

题意:

   给出柱状图各个柱子的高度,计算最大矩形面积。

思路:

   对每个柱子找到最大的宽的长度,将面积存进数组sort,输出最大面积。

具体实现:

   要利用单调栈,下面给出两种代码,分别是记录左右区间和不记录区间只找出最大宽度。

 1、记录左右区间(例题:Largest Rectangle in a Histogram) 感谢:Frank__Chen

#include<stdio.h>
#include<algorithm>
using namespace std;
typedef long long LL;
const LL MAX=1e5;
LL n;
LL high[MAX+5];
LL top;
LL Stack[MAX+5],l[MAX+5],r[MAX+5];
int main()
{
    while(scanf("%lld",&n)!=EOF){
        if(n==0){
            break;
        }
        for(LL i=1;i<=n;i++){
            scanf("%lld",&high[i]);
        }
        high[0]=-1,high[n+1]=-1;
        top=0;
        Stack[top]=0;
        for(LL i=1;i<=n;i++){
            while(high[Stack[top]]>=high[i]) top--;
            l[i]=Stack[top];
            Stack[++top]=i;
        }
        top=0;
        Stack[top]=n+1;
        for(LL i=n;i>=1;i--){
            while(high[Stack[top]]>=high[i]) top--;
            r[i]=Stack[top];
            Stack[++top]=i;
        }
        LL maxx=-MAX;
        for(LL i=1;i<=n;i++){
            maxx=max(maxx,(r[i]-l[i]-1)*high[i]);
        }
        printf("%lld\n",maxx);
    }
    return 0;
}

  2、直接利用单调栈性质计算最大宽度   感谢:Parsnip_

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值