PAT甲级 1007 Maximum Subsequence Sum

PAT甲级 1007 Maximum Subsequence Sum

问题描述

Given a sequence of K integers { N​1​​ , N​2​​ , …, NK​​ }. A continuous subsequence is defined to be { N​i , Ni+1​​ , …, Nj​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:
10 1 4

题目分析

题目指明给出一个整数序列,要求求出其中连续的和最大的子序列的和以及子序列最左端元素和最右端元素。

输入格式:
总记录人数
元素总数N
元素1、元素2…元素N

输出格式:
子序列和 左端元素 右端元素

解决方法:

对于本题,实质上就是求解最大连续子序列的和以及左右端元素,最大连续子序列属于经典的动态规划问题,所以本体采用的方法就是动态规划。

#include<iostream>
using namespace std;
int main(){
    int K;
    cin>>K;
    int sum=0;
    int num[10001];
    int R=0,L=0,l=0;              //R L为左右端索引
    int max=-999999;
    for(int i=0;i<K;i++){
        cin>>num[i];
        sum+=num[i];              //序列和
        if(sum>max){
            max=sum;
            R=i;
            L=l;
        }
        if(sum<=0){
            l=i+1;
            sum=0;
        }
    }
    if(max<0){
        max=0;
        L=0;
        R=K-1;
    }
    cout<<max<<" "<<num[L]<<" "<<num[R]<<endl;
}

处理结果:

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值