Oil Deposits HDU - 1241 题解(bfs+涂色)

Oil Deposits HDU - 1241

题目

Oil Deposits HDU - 1241
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

Sample Output

0
1
2
2

分析

本题用bfs加涂色做十分简单。首先遍历途中每一个点,直到找到石油,且该石油没有颜色,即还没被访问过。接着bfs这个点,找到该点的联通块,并涂上相应的颜色。如果后面再访问到这个联通块的点,只需要输出颜色的数量就可以了。

千万不要将涂色想的太过复杂,其实它就是记忆化搜索的一种应用。想想看,平常使用搜索算法时是不是会有一个vis数组用来判定每个点是否被访问过?而唯一的不同就是vis的值一般为0或1,而color是会随着bfs的次数而增加的,即每访问到一个新的联通块就让color的数量加一,也就是说,访问数组被赋予了更多的意义。

涂色的最大好处就是可以减少bfs的次数和数组的初始化。

具体的解题过程可以看我的代码注释~

代码

#include<iostream>
#include<queue>
#include<cstring>
using namespace std;

int m,n;
int map[110][110];
int dir[8][2] = {{0,1},{1,0},{-1,0},{0,-1},{-1,-1},{-1,1},{1,1},{1,-1}}; //八个方向
int ans; //方案数(颜色)
int color[110][110]; //记录颜色,判断是否被访问过

void bfs(int x,int y){
	queue<int> q;
	q.push(x); //起点入队
	q.push(y);
	color[x][y] = ans; 
	
	while(!q.empty()){
		int xx = q.front();
		q.pop();
		int yy = q.front();
		q.pop();
		
		for(int i = 0;i < 8;i++){ //遍历8个方向
			int xxx = xx + dir[i][0];
			int yyy = yy + dir[i][1];
			
			if(xxx < 1 || xxx > m || yyy < 1 || yyy > n || !map[xxx][yyy] || color[xxx][yyy] == ans) //边界判定+石油判定+访问判断
				continue;
			color[xxx][yyy] = ans; //记录颜色
			
			q.push(xxx); //新点入队
			q.push(yyy);
		}
		
	}
}

int main(){
	cin>>m>>n;

	while(m){
		for(int i = 1;i <= m;i++){
			for(int j = 1;j <= n;j++){
				char c;
				cin>>c;
				if(c == '@') //初始化地图
					map[i][j] = 1;
				else
					map[i][j] = 0;
			}
		}
		
		for(int i = 1;i <= m;i++){
			for(int j = 1;j <= n;j++){
				if(map[i][j] == 1 && !color[i][j]){ //如果有石油没有颜色就bfs一遍
					ans++;
					bfs(i,j);
				}
			}
		}
		cout<<ans<<endl; //颜色数即联通块的个数
		ans = 0;
		memset(color,0,sizeof(color));
		cin>>m>>n;
	}
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值