POJ 1384.Piggy-Bank - 完全背包

POJ 1384.Piggy-Bank - 完全背包

题干

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained.
The main income for this action comes from Irreversibly Bound Money (IBM).
The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank.
You know that this process is irreversible, the coins cannot be removed without breaking the pig.
After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.
But there is a big problem with piggy-banks. It is not possible to determine how much money is inside.
So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation.
The only possibility is to weigh the piggy-bank and try to guess how many coins are inside.
Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency.
Then there is some minimum amount of money in the piggy-bank that we can guarantee.
Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file.
Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins.
Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000.
On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency.
Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000).
P is the value of the coin in monetary units, W is it’s weight in grams.

Output
Print exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.”
where X is the minimum amount of money that can be achieved using coins with the given total weight.
If the weight cannot be reached exactly, print a line “This is impossible.”.

Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

知识点&算法

一手完全背包,即每种物品的可选数是无限的。
外层循环枚举物品种类,内层循环枚举背包容量(正序)。
和01背包不同,01背包对于每种物品只存在选与不选两种选择,因此要在容量枚举时倒序枚举以保证下标较小的状态还是考虑上个物品的状态。而完全背包的当前状态可能由选择过当前物品的情况推得,
因此正序枚举背包容量可以完全覆盖多次选择同一种类物品的情况。
另外根据题目不同,存在背包必须装满和背包不用装满的情况:
当背包不用装满时,dp数组应全部初始化为0,因为不用装满意味着我可以什么都不装
而当背包必须装满时,dp数组应该全部初始化为最大值/最小值(分别对应求背包装价值最小值/最大值),因为除开背包容量为0时(装不进东西所以价值为0),其他容量的情况下一定有一个对应装入的不为0价值(除非装不下,则数组仍为最值)

题解

#include <bits/stdc++.h>

using namespace std;
typedef long long ll;
int emp,full,diff,types;
int val[505],weight[505],dp[10005];

int main()
{
    int __;
    cin>>__;
    while(__--){
        scanf("%d%d",&emp,&full);
        diff = full - emp;
        scanf("%d",&types);
        for(int i = 0 ; i < types ; ++i) scanf("%d%d",val+i,weight+i);
        memset(dp,0x3f3f3f3f,sizeof(dp));
        dp[0] = 0;
        for(int i = 0 ; i < types ; ++i){
            for(int j = weight[i] ; j <= diff ; ++j){
                dp[j] = min(dp[j],dp[j - weight[i]] + val[i]);
            }
        }
        if(dp[diff] == 0x3f3f3f3f) cout<<"This is impossible."<<endl;
        else cout<<"The minimum amount of money in the piggy-bank is "<<dp[diff]<<"."<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值