PAT甲级1153

1153 Decode Registration Card of PAT (25 分)

A registration card number of PAT consists of 4 parts:

the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
the 2nd - 4th digits are the test site number, ranged from 101 to 999;
the 5th - 10th digits give the test date, in the form of yymmdd;
finally the 11th - 13th digits are the testee’s number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​) and M (≤100), the numbers of cards and the queries, respectively.
Then N lines follow, each gives a card number and the owner’s score (integer in [0,100]), separated by a space.
After the info of testees, there are M lines, each gives a query in the format Type Term, where

Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt’s, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98

Case 2: 2 107
3 260

Case 3: 3 180908
107 2
123 2
102 1

Case 4: 2 999
NA

代码

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <string>
#include <cmath>
#include <vector>
using namespace std;
struct student
{
	string level;
	string site;
	string date;
	string num;
	int score;
}stu;
struct answer
{
	int score;
	int site;
	int cnt;
}ans;

bool cmp1(student s1, student s2)
{
	if(s1.score != s2.score)
		return s1.scroe > s2.score;
	else if(s1.level != s2.level)
		return s1.level < s2.level;
	else if(s1.date != s2.date)
		return s1.date < s2.date;
	else if(s1.num != s2.num)
		return s1.num < s2.num;
}
bool cmp2(answer a1, answer a2)
{
	if(a1.cnt != a2.cnt)
		return a1.cnt > a2.cnt;
	else if(a1.site != a2.site)
		return a1.site < a2.site;
}
int main()
{
	int n, m;
	scanf("%d %d", &n, &m);
	string info;
	vector<student> s;
	for(int i = 0; i < n; i++){
		cin >> info;
		stu.level = info[0];
		stu.site  = info.substr(1,3);
		stu.date  = info.substr(4,6);
		stu.num   = info.substr(10,3);
		scanf("%d", &stu.score);
		s.push_back(stu);
	}
	sort(s.begin(), s.end(), cmp1);
	for(int i = 0; i < m; i++){
		int choose;
		scanf("%d", &choose);
		if(choose == 1){
			string t;
			int flag = 0;
			cin >> t;
			printf("Case %d: %d %s\n", i+1, choose, t.c_str());
			for(int j = 0; j < s.size(); j++){
				if(s[j].level == t){
					cout << s[j].level << s[j].site << s[j].date << s[j].num;
					printf(" %d\n", s[j].score);
					flag = 1;
				}
				if(flag == 0)
					printf("NA\n"); 
			}
		}
		if(choose == 2){
			string t;
			cin >> t;
			printf("Case %d: %d %s\n", i+1, choose, t.c_str());
			int sum = 0;
			int cnt = 0;
			for(int j = 0; j < s.size(); j++){
				if(s[j].site == t){
					sum += s[j].score;
					cnt++;
				}
			}
			if(cnt != 0)
				printf("%d %d\n", cnt, sum);
			else 
				printf("NA\n");
		}
		if(choose == 3){
			string t;
			cin >> t;
			printf("Case %d: %d %s\n", i+1, choose, t.c_str());
			int flag = 0;
			int num[1000] = {0};
			vector<answer> v;
			for(int j = 0; j < s.size(); j++){
				if(s[j].date == t){
					num[stoi(s[j].site)]++;
					flag = 1;
				}
			} 
			for(int k = 0; k < 1000; k++{
				if(num[k] != 0){
					ans.site = k;
					ans.cnt = num[k];
					v.push_back(ans);
				}
			}
			sort(v.begin(), v.end(), cmp2);
			for(int l = 0; l < v.size(); l++)
				printf("%d %d\n", v[l].site, v[l].cnt);
			if(flag == 0)
				printf("NA\n");
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值