1031 Hello World for U (20分)

问题

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h d
e l
l r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.
Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.
Output Specification:

For each test case, print the input string in the shape of U as specified in the description.
Sample Input:

helloworld!

Sample Output:

h !
e d
l l
lowor

解决方法

string

分析:图形输出
这道题的关键在于找到n1,n2,n3与N的关系。
在这里插入图片描述
n2 = n - 2 * n1+2;

#include<iostream>
#include<string>
using namespace std;
int main()
{
	string s;
	cin >> s;
	int n = s.size();
	int n1 =(n+2)/ 3;
	int n3 = n - 2 * n1+2;
	for (int i = 0; i < n1; i++)
	{
		if (i == n1 - 1)
		{
			for (int j = n1-1; j <= n - n1; j++)
			{
				cout << s[j];
			}
			cout << endl;
		}
		else
		{
			cout << s[i];
			for (int j = 0; j < n3 - 2; j++)
			{
				cout << " ";
			}
			cout << s[n - i - 1] << endl;
		}
	}
	return 0;
}

二维数组

分析:图形输出
把字符串存储到二维字符数组中,一开始初始化字符数组为空格,然后按照U型填进数组,最后输出。

#include<iostream>
#include<string>
using namespace std;
int main()
{
	string s;
	cin >> s;
	char u[30][30];
	memset(u, ' ', sizeof(u));//或者写成char u[30][30]={' '}
	int index = 0;
	int n = s.size();
	int n1 = (n+2) / 3;
	int n2 = n +2- 2 * n1;
	for (int i = 0; i < n1; i++) u[i][0] = s[index++];
	for (int i = 1; i <=n2-2; i++) u[n1-1][i] = s[index++];
	for (int i = n1-1; i >= 0; i--) u[i][n2-1] = s[index++];
	for (int i = 0; i < n1; i++)
	{
		for (int j = 0; j < n2; j++)
		{
			cout << u[i][j];
		}
		cout << endl;
	}
	return 0;
}

后记

最开始只写出来string的做法,后看了柳神的代码,又尝试着写二维数组的做法。但是最开始二维数组的初始化出现问题,因为自己对二维数组的不熟悉。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值