通用版2.I - Safecracker (待看

=== Op tech briefing, 2002/11/02 06:42 CST === 
"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary." 

v - w^2 + x^3 - y^4 + z^5 = target 

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then." 

=== Op tech directive, computer division, 2002/11/02 12:30 CST === 

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution' if there is no correct combination. Use the exact format shown below." 
Input
1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END
Output
LKEBA
YOXUZ
GHOST
no solution
Sample Input
1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END
Sample Output
LKEBA
YOXUZ
GHOST
no solution
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
using namespace std;
int f(int x,int a)
{
    int i,s=1;
    for(i=1;i<=a;i++){
        s=s*x;
    }
    return s;
}
int main()
{
    int v,w,x,y,z,n,m,flag,i;
    char s[100],re[7],be[7],uu[100];
    while(scanf("%d%s",&n,s)){
        if(!n&&strcmp(s,"END")==0)break;
        m=strlen(s);
        sort(s,s+m);
        memset(re,0,sizeof(re));
        memset(be,0,sizeof(be));
        flag=0;
        for(i=0;i<=m-1;i++){
            uu[i]=s[i]-'A'+1;
        }
        for(v=0;v<=m-1;v++){
            for(w=0;w<=m-1;w++){
                if(v==w)continue;
                for(x=0;x<=m-1;x++){
                    if(x==v||x==w)continue;
                    for(y=0;y<=m-1;y++){
                        if(y==v||y==w||y==x)continue;
                        for(z=0;z<=m-1;z++){
                            if(z==v||z==w||z==x||z==y)continue;
                            if(uu[v]-f(uu[w],2)+f(uu[x],3)-f(uu[y],4)+f(uu[z],5)==n){
                                re[0]=s[v],re[1]=s[w],re[2]=s[x],re[3]=s[y],re[4]=s[z];
                                re[5]='\0';
                                if(strcmp(re,be)>0) strcpy(be,re);
                                flag=1;
                            }
                        }
                    }
                }
            }
        }
        if(flag==1)puts(be);
        else printf("no solution\n");
    }
    return 0;
}

题意是给一个数,一串大写字母,在大写字母里找五个字母满足v-w^2+x^3-y^4+z^5==给出的数字,并且这五个字母构成的字符串必须是字典序最大的,A=1,B=2,C=3...

这道题我是暴力过的,感觉很奇幻,都不知道为啥能过,然后去查了一下,有人用dfs写的

贴个地址 http://blog.csdn.net/lnformat/article/details/53461841

用dfs写了一下,好多bug,怀疑人生。。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值