D - Fliptile

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input

Line 1: Two space-separated integers: M and N
Lines 2…M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1…M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

如果不能全部弄灭,输出IMPOSSIBLE

如果能够全部弄灭,就输出按动最小次数对应的方法。如果有多种方法均为最小次数,则输出字典序最小的方法。

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int INF = 0x3f3f3f3f;

int m, n, cnt = INF; // cnt记录需要按动的最小次数 
int ma[20][20], t[20][20]; // 原始状态的备份 
bool res[20][20], tt[20][20]; // 当前的方法 
int dx[] = {1, -1, 0, 0}, dy[] = {0, 0, 1, -1};
// 按动地板 
void op(int x, int y)
{
	tt[x][y] = 1;
	ma[x][y] ^= 1;
	for (int i = 0; i < 4; i++) {
		int nx = x + dx[i], ny = y + dy[i];
		if (nx >= 0 && nx < m && ny >= 0 && ny < n) {
			ma[nx][ny] ^= 1;
		} 
	}
}

void dfs(int x, int state)
{
	if (x == m) {
		bool flag = 1;
		for (int j = 0; j < n; j++) {
			if (ma[m - 1][j] == 1) {
				flag = 0;
				break;
			}
		}
		// 最后一排全灭
		if (flag == 1) {
			if (cnt > state) {
				cnt = state;
				memcpy(res, tt, sizeof tt);
			}
		}
		return;
	}
	for (int j = 0; j < n; j++) {
		if (ma[x - 1][j] == 1) {
			op(x, j);
			state++;
		}
	}
	
	dfs(x + 1, state);
}

int main(void)
{
	cin >> m >> n;
	for (int i = 0; i < m; i++) {
		for (int j = 0; j < n; j++) {
			cin >> t[i][j];
		}
	}
	// 用 0 - 2^n-1 对应字典序从小到大的方法 
	for (int i = 0; i < 1 << n; i++) {
		memset(tt, 0, sizeof tt);
		memcpy(ma, t, sizeof t);
		int num = 0;
		for (int j = 0; j < n; j++) {
			// 如果当前位上的数字为 1 
			if (i >> (n - 1 - j) & 1) {
				op(0, j);
				num++;
			}
		}
		dfs(1, num);
	}
	// 如果未被更新过 
	if (cnt == INF) {
		cout << "IMPOSSIBLE" << endl;
	} else {
		for (int i = 0; i < m; i++) {
			for (int j = 0; j < n; j++) {
				cout << res[i][j] << " ";
			}
			cout << endl;
		}
	}
	
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值