尺取法模板

尺取法,也叫双指针,是一种O(n)复杂度的算法,通过调整区间的左右端点,来找到满足要求的区间

Subsequence

POJ3061

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

Source

Southeastern Europe 2006

一道标准的尺取法模板题,求区间和大于s的最小区间长度。

下面这种写法比较规整,方便记忆

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int N = 1e5 + 5, INF = 0x3f3f3f3f;

int a[N];

int main(void)
{
	int t, n, s;
	cin >> t;
	while (t--) {
		scanf("%d%d", &n, &s);
		for (int i = 0; i < n; i++) 
			scanf("%d", &a[i]);
		int res = INF;
		for (int l = 0, r = 0, sum = 0; r < n; r++) {
			sum += a[r];
			while (sum >= s) {
				res = min(res, r - l + 1);
				sum -= a[l++];
			}
		}
		cout << (res == INF ? 0 : res) << endl;
	}
	
	return 0;
}

还有一道尺取法的题,在云淮杯那篇博客的H题

合成质数

给定一个数n,它可以用一个或多个连续的质数的合成(一个重量的椰子只能用一次),求出有多少种合成方式?

#include <bits/stdc++.h>
using namespace std;
const int N = 1e5 + 5;

bool is_prime[N];
int prime[N];

int sieve(int n)
{
	for (int i = 2; i <= n; i++)
		is_prime[i] = 1;
	int cnt = 0;
	for (int i = 2; i <= n; i++) {
		if (is_prime[i]) {
			prime[cnt++] = i;
			for (int j = 2 * i; j <= n; j += i) {
				is_prime[j] = 0;
			}
		}
	}
	return cnt;
}

int main(void)
{
	int cnt = sieve(N);
	cout << cnt << endl;
	
	int n, res;
	while (scanf("%d", &n) != EOF && n) {
		res = 0;
		for (int l = 0, r = 0, sum = 0; r < cnt; r++) {
			sum += prime[r];
			while (sum > n) {
				sum -= prime[l++];
			} 
			if (sum == n) {
				res++;
			} 
		}
		printf("%d\n", res);
	}
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值