E - Period(kmp)

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

每组给一个字符串,遍历字符串的前缀,看前缀能否由两个或以上的相同字符串连在一起组成。如果可以,那么就输出前缀的长度和周期数目。

当i % (i - Next[i]) == 0时,表示当前可能的最小循环节长度为i / (i - Next[i])

感觉这道题跟F题很像,都是利用next失配数组来求最小循环节,再进行判断周期数目,符合条件的话就进行输出。

#include <bits/stdc++.h>
using namespace std;
const int N = 1e6 + 5; 

char a[N], b[N];
int Next[N], f[N]; // Next是字符串 a 和自己匹配,f是字符串 a 和 b 匹配 
int n, m;
// 求解 Next 数组
void get_next()
{
	Next[1] = 0;
	for (int i = 2, j = 0; i <= n; i++) {
		while (j > 0 && a[i] != a[j + 1]) j = Next[j];
		if (a[i] == a[j + 1]) j++;
		Next[i] = j;
	}
}

void kmp()
{
	for (int i = 1, j = 0; i <= m; i++) {
		while (j > 0 && (j == n || b[i] != a[j + 1])) j = Next[j];
		if (b[i] == a[j + 1]) j++;
		f[i] = j;
		// if (f[i] == n) 此时就是 A 在 B 中的某一次出现 
	}
}

int main(void)
{
	int idx = 1;
	while (scanf("%d", &n) != EOF && n) { 
		scanf("%s", a + 1); // a 为较短的字符串 
		n = strlen(a + 1);
		get_next();
		cout << "Test case #" << idx++ << endl;
		for (int i = 1; i <= n; i++) {
			if (i % (i - Next[i]) == 0 && i / (i - Next[i]) >= 2) {
				cout << i << " " << i / (i - Next[i]) << endl;
			}
		} 
		cout << endl;
	}
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值