PAT_A1035 | Password

1035 Password (20point(s))

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

 

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

 

Sample Input 2:

1
team110 abcdefg332

 

Sample Output 2:

There is 1 account and no account is modified

 

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

 

Sample Output 3:

There are 2 accounts and no account is modified

每个学生有两个元素,名字和密码,考虑存入结构体中。而且学生数目不超过1000,所以需要一个结构体数组来储存数据。

 

将输入的字符串依次存入结构体中,并检验是否合格,如果不合格要做如下改动:

1  ->  @

0 ->  %

l ->  L

O ->  o

并同时记录改动的密码个数,和不合格的结构体数组下标,最后按照要求输出即可。

 

代码如下:

//
// Created by LittleCat on 2020/2/10.
//

#include <cstdio>

#define N 12
#define STU 1005

struct student {
    char name[N];
    char password[N];
} stu[STU];

bool isValid(char c) {
    return c != '1' && c != '0' && c != 'l' && c != 'O';
}

int main() {
    int n;
    scanf("%d", &n);

    int ans[STU], count = 0;
    for (int i = 0; i < n; i++) {

        scanf("%s %s", stu[i].name, stu[i].password);

        bool flag = true;  //记录密码是否合格
        /* 遍历整个密码串 */
        for (int j = 0; stu[i].password[j] != '\0'; j++) {

            char c = stu[i].password[j];
            if (!isValid(c)) {
                flag = false;  //记录不合格
                //修改
                if (c == '1')
                    stu[i].password[j] = '@';
                else if (c == '0')
                    stu[i].password[j] = '%';
                else if (c == 'l')
                    stu[i].password[j] = 'L';
                else
                    stu[i].password[j] = 'o';
            }
        }
        if (!flag)
            ans[count++] = i;   //记录下不合格密码对应的学生下标
    }

    /* 输出 */
    if (count == 0) {
        if (n == 1)
            printf("There is 1 account and no account is modified\n");
        else
            printf("There are %d accounts and no account is modified\n", n);
    } else {
        printf("%d\n", count);
        for (int i = 0; i < count; i++)
            printf("%s %s\n", stu[ans[i]].name, stu[ans[i]].password);
    }
}


end 

欢迎关注个人公众号 鸡翅编程 ”,这里是认真且乖巧的码农一枚。

---- 做最乖巧的博客er,做最扎实的程序员 ----

旨在用心写好每一篇文章,平常会把笔记汇总成推送更新~

在这里插入图片描述

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值