W - Test for Job (记忆化搜索)

17 篇文章 0 订阅

 

Mr.Dog was fired by his company. In order to support his family, he must find a new job as soon as possible. Nowadays, It's hard to have a job, since there are swelling numbers of the unemployed. So some companies often use hard tests for their recruitment.

The test is like this: starting from a source-city, you may pass through some directed roads to reach another city. Each time you reach a city, you can earn some profit or pay some fee, Let this process continue until you reach a target-city. The boss will compute the expense you spent for your trip and the profit you have just obtained. Finally, he will decide whether you can be hired.

In order to get the job, Mr.Dog managed to obtain the knowledge of the net profit Viof all cities he may reach (a negative Vi indicates that money is spent rather than gained) and the connection between cities. A city with no roads leading to it is a source-city and a city with no roads leading to other cities is a target-city. The mission of Mr.Dog is to start from a source-city and choose a route leading to a target-city through which he can get the maximum profit.

Input

The input file includes several test cases. 
The first line of each test case contains 2 integers n and m(1 ≤ n ≤ 100000, 0 ≤m ≤ 1000000) indicating the number of cities and roads. 
The next n lines each contain a single integer. The ith line describes the net profit of the city iVi (0 ≤ | Vi| ≤ 20000) 
The next m lines each contain two integers xy indicating that there is a road leads from city x to city y. It is guaranteed that each road appears exactly once, and there is no way to return to a previous city. 

Output

The output file contains one line for each test cases, in which contains an integer indicating the maximum profit Dog is able to obtain (or the minimum expenditure to spend)

Sample Input

6 5
1
2
2
3
3
4
1 2
1 3
2 4
3 4
5 6

Sample Output

7

Hint

题解:找寻一条从入度为0的起点到出度为0的终点的最长路径(可能为负,但最大的特点是不变的)。DFS一波~~~

总体来说:前向星比vector快了接近1秒(这个题)

1:前向星存图版本:

#include<iostream>
#include<cstring>
#include<stdio.h>
using namespace std;
const int maxn=100010;
const int INF=0x3f3f3f3f;
int n,m,cnt,x[maxn],dp[maxn],vis[maxn],in[maxn],head[maxn];
struct Edge
{
    int v,next;
}e[maxn*10];
void add(int u,int v)
{
    e[cnt].v=v;
    e[cnt].next=head[u];
    head[u]=cnt++;
}
void Init()
{
    cnt=1;
    memset(vis,0,sizeof(vis));
    memset(in,0,sizeof(in));
    memset(head,-1,sizeof(head));
    memset(dp,-INF,sizeof(dp));
}
void DFS(int u)
{
    vis[u]=1;
    if(head[u]==-1)     //u没有出边,即为终点
    {
        dp[u]=x[u];
        return ;
    }
    for(int i=head[u];i!=-1;i=e[i].next)
    {
        int v=e[i].v;
        if(!vis[v])
            DFS(v);
        dp[u]=max(dp[u],x[u]+dp[v]);
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m)) //注意加波浪线~~~,否则会T
    {
        Init();
        for(int i=1;i<=n;i++)
            scanf("%d",&x[i]);
        for(int i=1;i<=m;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            in[v]++;    //判起点,入度为0为起点
            add(u,v);
        }
        int ans=-INF;
        for(int i=1;i<=n;i++)
        {
            if(in[i]==0)
            {
                DFS(i);     //只DFS起点即可
                ans=max(ans,dp[i]);
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

 2:vector动态数组版本:

#include<iostream>
#include<cstring>
#include<stdio.h>
#include<vector>
using namespace std;
const int maxn=100010;
const int INF=0x3f3f3f3f;
int n,m,cnt,x[maxn],dp[maxn],vis[maxn],in[maxn];
vector<int>e[maxn];
void Init()
{
    for(int i=0;i<maxn;i++)
    {
        vis[i]=0;
        in[i]=0;
        dp[i]=-INF;
        e[i].clear();
    }
}
void DFS(int u)
{
    vis[u]=1;
    int len=e[u].size();
    if(len==0)             //没有出边,即为终点
    {
        dp[u]=x[u];
        return ;
    }
    for(int i=0;i<len;i++)
    {
        int v=e[u][i];
        if(!vis[v])
        {
            DFS(v);
        }
        dp[u]=max(dp[u],x[u]+dp[v]);
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m)) //注意加波浪线~~~,否则会T
    {
        Init();
        for(int i=1;i<=n;i++)
            scanf("%d",&x[i]);
        for(int i=1;i<=m;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            e[u].push_back(v);
            in[v]++;
        }
        int ans=-INF;
        for(int i=1;i<=n;i++)
        {
            if(in[i]==0)
            {
                DFS(i);
                ans=max(ans,dp[i]);
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值