Check the difficulty of problems (POJ-2151)概率DP

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:
1. All of the teams solve at least one problem.
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972

题意:一套题,有T个题,M个团队参加比赛,已知每个团队做出来某题的概率。问你,你能计算出所有团队至少解决一个问题,同时冠军团队解决至少N问题的概率吗?

思路:可以把所有考生都至少做来一道题的概率减去 每个人都做来1到n-1道题的概率。

p=[(1-x11)*(1-x12)(..) ] * [(1-x21)*(1-x22)(..)]*[...]     -    [...]*[...] ,这样的话,用组合数就ok了。

但是这里是用的DP是思路,先把考生与考题的关系求出来,dp[i][j][k] 表示第i个考试前j个题会做k道的概率。再根据题意进行分情况DP。

AC代码:

#include <stdio.h>
#include <string>
#include <string.h>
#include <algorithm>
#include <iostream>
#include <math.h>
#include<iomanip>
const int maxx=1010;
const int inf=0x3f3f3f3f;
using namespace std;
double dp[maxx][35][35];
double a[maxx][35];
int main()
{
    int m,t,n;
    while(cin>>m>>t>>n)
    {
        if(m==0 && t==0 && n==0)
            break;
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=t; i++)
        {
            for(int j=1; j<=m; j++)
            {
                cin>>a[i][j];
            }
        }
        for(int i=1; i<=t; i++)
        {
            for(int j=0; j<=m; j++)
            {
                for(int k=0; k<=j; k++)
                {
                    if(j==0 && k==0)
                        dp[i][j][k]=1;
                    else if(j==k)
                        dp[i][j][k]=dp[i][j-1][k-1]*a[i][j];
                    else if(k==0)
                        dp[i][j][k]=dp[i][j-1][k]*(1-a[i][j]);
                    else
                        dp[i][j][k]=dp[i][j-1][k-1]*a[i][j]+dp[i][j-1][k]*(1-a[i][j]);
                }
            }
        }
        double ans=1,p1=1,tmp;
        for(int i=1; i<=t; i++)
        {
            p1*=(1-dp[i][m][0]);
            tmp=0;
            for(int j=1; j<n; j++)
                tmp+=dp[i][m][j];
            ans*=tmp;
        }
        ans=p1-ans;
        cout<<fixed<<setprecision(3)<<ans<<endl;
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值