How Many Tables(并查集)

How Many Tables(并查集)

问题描述:
Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
(今天是伊格那丢的生日。他邀请了很多朋友。现在该吃晚饭了。伊格那丢想知道他至少需要多少张桌子。你必须注意到,并不是所有的朋友都认识对方,所有的朋友都不想和陌生人待在一起。
这个问题的一个重要规则是如果我告诉你A知道B, B知道C,这意味着A, B, C相互知道,所以它们可以在一个表中。
例如:如果我告诉你A知道B, B知道C, D知道E,那么A, B, C可以留在一个表中,D, E必须留在另一个表中。Ignatius至少需要两个表。)
输入描述:
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
(输入以一个整数T(1<=T<=25)开始,它表示测试用例的数量。然后是T测试用例。每个测试用例以两个整数N和M开始(1<=N,M<=1000)。N表示好友的数量,好友标记从1到N,然后是M行。每一行由两个整数A和B(A!=B)组成,这意味着朋友A和朋友B彼此认识。两种情况之间有一条空白线。)
输出描述:
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
(对于每个测试用例,只需输出Ignatius至少需要多少个表。不要打印任何空白。)
样例输入:
2
5 3
1 2
2 3
4 5

5 1
2 5
样例输出:
2
4
AC代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <iostream>
int pre[1010];
int getf(int a)
{
    if(a==pre[a])
        return a;
    pre[a] = getf(pre[a]);
    return pre[a];
}
void mer(int a, int b)
{
    int fa = getf(a);
    int fb = getf(b);
    if(fa != fb)
        pre[fa] = fb;
}
int main()
{
    int t,n,m,x,y;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&n, &m);
        for(int i = 1; i <= n; ++i)
            pre[i] = i;
        while(m--)
        {
            scanf("%d %d",&x, &y);
            mer(x,y);
        }
        int ans = 0;
        for(int i = 1; i <= n; ++i)
            if(pre[i] == i)
                ++ans;
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值