PAT练习题 P1012 The Best Rank (25分) 【结构体运用】


传送门:P1012


P1012 The Best Rank (25分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/Ajing


解题思路:
本题考查我们对于结构体的运用,构造一个 student 结构体,依次存进一个 vector 容器中,进行四次排序(按优先级 A > C > M > E),每次都将该排序记录(取最好的排名,及对应的科目),注意如果出现成绩相同是会少一个排名的,如1 1 3 4
最后用一个 map 使学生 ID 对应 vector 里的顺序,方便查询。


AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<vector>
#include<map>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
struct student
{
  int C,M,E,A;
  int ID;
  int bestrank;
  char bestmethod;
};
int n,m;
bool cmpA(student a,student b)
{
  return a.A>b.A;
}
bool cmpC(student a,student b)
{
  return a.C>b.C;
}
bool cmpM(student a,student b)
{
  return a.M>b.M;
}
bool cmpE(student a,student b)
{
  return a.E>b.E;
}

int main()
{
  scanf("%d%d",&n,&m);
  vector<student> stu;
  for(int i=0;i<n;i++)
  {
    student s;
    scanf("%d%d%d%d",&s.ID,&s.C,&s.M,&s.E);
    s.A=(s.C+s.M+s.E)/3;
    stu.push_back(s);
  }
  sort(stu.begin(),stu.end(),cmpA);
  stu[0].bestrank=1;
  stu[0].bestmethod='A';
  int rank=1;
  for(int i=1;i<n;i++)
  {
    if(stu[i].A<stu[i-1].A)
      rank=i+1;
    stu[i].bestrank=rank;
    stu[i].bestmethod='A';
  }
  sort(stu.begin(),stu.end(),cmpC);
  rank=1;
  if(stu[0].bestrank!=1)
  {
    stu[0].bestrank=1;
    stu[0].bestmethod='C';
  }
  for(int i=1;i<n;i++)
  {
    if(stu[i].C<stu[i-1].C)
      rank=i+1;
    if(rank<stu[i].bestrank)
    {
      stu[i].bestrank=rank;
      stu[i].bestmethod='C';
    }
  }
  sort(stu.begin(),stu.end(),cmpM);
  rank=1;
  if(stu[0].bestrank!=1)
  {
    stu[0].bestrank=1;
    stu[0].bestmethod='M';
  }
  for(int i=1;i<n;i++)
  {
    if(stu[i].M<stu[i-1].M)
      rank=i+1;
    if(rank<stu[i].bestrank)
    {
      stu[i].bestrank=rank;
      stu[i].bestmethod='M';
    }
  }
  sort(stu.begin(),stu.end(),cmpE);
  rank=1;
  if(stu[0].bestrank!=1)
  {
    stu[0].bestrank=1;
    stu[0].bestmethod='E';
  }
  for(int i=1;i<n;i++)
  {
    if(stu[i].E<stu[i-1].E)
      rank=i+1;
    if(rank<stu[i].bestrank)
    {
      stu[i].bestrank=rank;
      stu[i].bestmethod='E';
    }
  }
  map<int,int> mp;
  for(int i=0;i<n;i++)
  {
    mp[stu[i].ID]=i;
  }
  int id;
  for(int i=0;i<m;i++)
  {
    scanf("%d",&id);
    if(mp.find(id)==mp.end())
      printf("N/A\n");
    else
      printf("%d %c\n",stu[mp[id]].bestrank,stu[mp[id]].bestmethod);
  }
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值