算法初步--PAT1012 The best rank

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

题目大意就是:输入n个学生的姓名id,C语言分数,数学分数,英语分数,再给出m个学生的姓名id,输出这m个学生各自分数最高的一门科目和对应的排名,如果分数相同则排名相同,如果学生不存在在则输出N/A。

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define MAX 2000

int flag = 0;

typedef struct {
    int name;
    int score[4];        // 0~3分别为平均分,C语言,数学,英语,下面两个也同
    int rank[4];
    char priority[4];
} Student;

int cmp(const void* a, const void* b) {
    return (*(Student*)b).score[flag] - (*(Student*)a).score[flag];
}

int main() {
    int n, m, id;
    Student stu[MAX];
    scanf("%d%d", &n, &m);
    for (int i = 0; i < n; i++) {
        scanf("%d %d %d %d", &stu[i].name, &stu[i].score[1], &stu[i].score[2], &stu[i].score[3]);
        stu[i].score[0] = (stu[i].score[1] + stu[i].score[2] + stu[i].score[3]) / 3;
        stu[i].priority[0] = 'A';
        stu[i].priority[1] = 'C';
        stu[i].priority[2] = 'M';
        stu[i].priority[3] = 'E';
        //strcpy(stu[i].priority, "ACME");    // 有的编译器不通过

    }
    // 四次排序,每个学生每门课对应的排名填入结构体字段
    for (; flag < 4; flag++) {
        qsort(stu, n, sizeof(stu[0]), cmp);
        // 排序之后第一个排名一定是第一,后续如果与前一个学生分数相同,则用前一个学生的排名,如果不同,则排名等于i+1
        stu[0].rank[flag] = 1;
        for (int i = 1; i < n; i++) {
            if (stu[i].score[flag] != stu[i - 1].score[flag]) {
                stu[i].rank[flag] = i + 1;  // 每一科目对应的排名
            } else {
                stu[i].rank[flag] = stu[i - 1].rank[flag];
            }
        }
    }
    // index为排名最高那门课所在数组的索引
    int i, j, index;
    for (i = 0; i < m; i++) {
        scanf("%d", &id);
        for (j = 0; j < n; j++) {
            if (id == stu[j].name) {
                index = 0;
                for (int k = 0; k < 3; k++) {
                    if (stu[j].rank[index] > stu[j].rank[k + 1]) {
                        index = k + 1;
                    }
                }
                printf("%d %c", stu[j].rank[index], stu[j].priority[index]);
                break;
            }
        }
        if (j == n) printf("N/A");
        if (i != m - 1) printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值