HDU 3026 和 HDU 1814 【2-SAT模板题】


HDU 3062

Party
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description
有n对夫妻被邀请参加一个聚会,因为场地的问题,每对夫妻中只有1人可以列席。在2n 个人中,某些人之间有着很大的矛盾(当然夫妻之间是没有矛盾的),有矛盾的2个人是不会同时出现在聚会上的。有没有可能会有n 个人同时列席?

Input
n: 表示有n对夫妻被邀请 (n<= 1000)
m: 表示有m 对矛盾关系 ( m < (n - 1) * (n -1))
在接下来的m行中,每行会有4个数字,分别是 A1,A2,C1,C2
A1,A2分别表示是夫妻的编号
C1,C2 表示是妻子还是丈夫 ,0表示妻子 ,1是丈夫
夫妻编号从 0 到 n -1

Output
如果存在一种情况 则输出YES
否则输出 NO

Sample Input
2
1
0 1 1 1

Sample Output
YES


题解:
一对夫妻看成一个变量,之间的矛盾可以看成限制。
选了i就不选j,即必选j′。所以我们i→j′,j→i′连边。
套个2-SAT的模板即可。


AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<vector>
#include<cmath>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
const int N=1100;
int n,m;
vector<int> g[2*N];
int stack[2*N];
bool vis[2*N];
int top;
void init()//初始化
{
  for(int i=0;i<2*N;i++)
    g[i].clear();
  memset(vis,false,sizeof(vis));
}
void addedge(int x,int idx,int y,int idy)//建边
{
  x=2*x+idx;
  y=2*y+idy;
  g[x].push_back(y);
}
bool dfs(int x)
{
  if(vis[x^1]) return false;//此条件的反存在,不成立
  if(vis[x]) return true;//当此条件存在,则成立
  vis[x]=true;//假设此条件成立
  stack[++top]=x;//加入假设的条件
  int len=g[x].size();
  for(int i=0;i<len;i++)//此条件能推出的各种条件
  {
    if(!dfs(g[x][i]))
      return false;
  }
  return true;
}
bool twosat()
{
  for(int i=0;i<2*n;i+=2)
  {
    if(!vis[i]&&!vis[i+1])
    {
      top=0;
      if(!dfs(i))
      {
        while(top>0)
        {
          vis[stack[top--]]=false;
        }
        if(!dfs(i+1)) return false;
      }
    }
  }
  return true;
}
int main()
{
  int x,idx,y,idy;
  while(scanf("%d%d",&n,&m)!=EOF)
  {
    init();
    for(int i=0;i<m;i++)
    {
      scanf("%d%d%d%d",&x,&y,&idx,&idy);
      addedge(x,idx,y,idy^1);
      addedge(y,idy,x,idx^1);//关系矛盾是双方的
    }
    if(twosat())
    {
      printf("YES\n");
    }
    else
    {
      printf("NO\n");
    }
  }
  return 0;
}



HDU 1814

Peaceful Commission
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description
The Public Peace Commission should be legislated in Parliament of The Democratic Republic of Byteland according to The Very Important Law. Unfortunately one of the obstacles is the fact that some deputies do not get on with some others.
The Commission has to fulfill the following conditions:
1.Each party has exactly one representative in the Commission,
2.If two deputies do not like each other, they cannot both belong to the Commission.
Each party has exactly two deputies in the Parliament. All of them are numbered from 1 to 2n. Deputies with numbers 2i-1 and 2i belong to the i-th party .
Task
Write a program, which:
1.reads from the text file SPO.IN the number of parties and the pairs of deputies that are not on friendly terms,
2.decides whether it is possible to establish the Commission, and if so, proposes the list of members,
3.writes the result in the text file SPO.OUT.

Input
In the first line of the text file SPO.IN there are two non-negative integers n and m. They denote respectively: the number of parties, 1 <= n <= 8000, and the number of pairs of deputies, who do not like each other, 0 <= m <=2 0000. In each of the following m lines there is written one pair of integers a and b, 1 <= a < b <= 2n, separated by a single space. It means that the deputies a and b do not like each other.
There are multiple test cases. Process to end of file.

Output
The text file SPO.OUT should contain one word NIE (means NO in Polish), if the setting up of the Commission is impossible. In case when setting up of the Commission is possible the file SPO.OUT should contain n integers from the interval from 1 to 2n, written in the ascending order, indicating numbers of deputies who can form the Commission. Each of these numbers should be written in a separate line. If the Commission can be formed in various ways, your program may write mininum number sequence.

Sample Input
3 2
1 3
2 4

Sample Output
1
4
5


题意:
现有n个党派,每个党派需要在两个代表中选一个,这2n个代表中有彼此讨厌的m对人,输出去开会的代表(多解则输出字典序最小解)


题解:
输出字典序最小的结果,模板跑出来就是字典序最小的。
因为题目要求已经是2n,所以建边时不需要乘2。


AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<vector>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
const int N=8100;
bool mark[2*N];
int stack[2*N];
int n,m,top;
vector<int> g[2*N];
void init()
{
  memset(mark,false,sizeof(mark));
  for(int i=0;i<2*N;i++)
  {
    g[i].clear();
  }
}
void addedge(int x,int y)
{
  g[x].push_back(y^1);
  g[y].push_back(x^1);
}
bool dfs(int x)
{
  if(mark[x^1]) return false;
  if(mark[x]) return true;
  mark[x]=true;
  stack[++top]=x;
  int len=g[x].size();
  for(int i=0;i<len;i++)
  {
    if(!dfs(g[x][i])) return false;
  }
  return true;
}
bool twosat()
{
  for(int i=0;i<2*n;i+=2)
  {
    if(!mark[i]&&!mark[i+1])
    {
      top=0;
      if(!dfs(i))
      {
        while(top>0)
          mark[stack[top--]]=false;
        if(!dfs(i+1)) return false;
      }
    }
  }
  return true;
}
int main()
{
  int a,b;
  while(scanf("%d%d",&n,&m)!=EOF)
  {
    init();
    for(int i=0;i<m;i++)
    {
      scanf("%d%d",&a,&b);
      a--;b--;
      addedge(a,b);
    }
    if(twosat())
    {
      for(int i=0;i<2*n;i++)
      {
        if(mark[i]) printf("%d\n",i+1);
      }
    }
    else printf("NIE\n");
  }
  return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值