PTA Advanced 1157 Anniversary C++

目录

题目

Input Specification:

Output Specification:

Sample Input:

Sample Output:

思路

代码


题目

Zhejiang University is about to celebrate her 122th anniversary in 2019. To prepare for the celebration, the alumni association (校友会) has gathered the ID's of all her alumni. Now your job is to write a program to count the number of alumni among all the people who come to the celebration.

Input Specification:

Each input file contains one test case. For each case, the first part is about the information of all the alumni. Given in the first line is a positive integer N (≤105). Then N lines follow, each contains an ID number of an alumnus. An ID number is a string of 18 digits or the letter X. It is guaranteed that all the ID's are distinct.

The next part gives the information of all the people who come to the celebration. Again given in the first line is a positive integer M (≤105). Then M lines follow, each contains an ID number of a guest. It is guaranteed that all the ID's are distinct.

Output Specification:

First print in a line the number of alumni among all the people who come to the celebration. Then in the second line, print the ID of the oldest alumnus -- notice that the 7th - 14th digits of the ID gives one's birth date. If no alumnus comes, output the ID of the oldest guest instead. It is guaranteed that such an alumnus or guest is unique.

Sample Input:

5
372928196906118710
610481197806202213
440684198612150417
13072819571002001X
150702193604190912
6
530125197901260019
150702193604190912
220221196701020034
610481197806202213
440684198612150417
370205198709275042

Sample Output:

3
150702193604190912

思路

这题思路很简单:

用set存储校友的id;

然后扫描所有参会人id,比对set中是否存在这个id即可;

在这个过程中顺便统计一下参会人中最老的,以及其中是校友的人群中最老的

tips:补充一个设置string长度的函数:`str1.resize(18)`

代码

#include <iostream>
#include <set>
#include <string>

using namespace std;

// 如果id1比id2年龄大则返回true,否则返回false 
bool isOlder(string id1,string id2){
	for(int i=6;i<14;i++){
		if(id1[i]<id2[i]) return true;
		else if(id1[i]>id2[i]) return false;
	} 
	return false;
}

int main(int argc, char** argv) {
	int n,m,alumniNum=0;
	cin>>n;
	
	set<string> alumniId;
	string id; 
	for(int i=0;i<n;i++){
		cin>>id;
		alumniId.insert(id);
	}
	
	cin>>m;
	string oldestIdInAlumni;
	string oldestIdInAll;
	oldestIdInAlumni.resize(18);
	oldestIdInAll.resize(18); 
	for(int i=6;i<14;i++){
		oldestIdInAlumni[i]='9';
		oldestIdInAll[i]='9';
	}
	for(int i=0;i<m;i++){
		cin>>id;
		// 判断该id是否是校友的
		if(alumniId.count(id)==1){
			alumniNum++;
			// 判断该校友是否年龄更大
			if(isOlder(id,oldestIdInAlumni)) oldestIdInAlumni=id;
		} 
		
		// 找出所有人中年龄最大的
		if(isOlder(id,oldestIdInAll)) oldestIdInAll=id; 
	}
	
	cout<<alumniNum<<endl;
	if(alumniNum!=0) cout<<oldestIdInAlumni;
	else cout<<oldestIdInAll;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值