hdu 2588 GCD最详细讲解

12 篇文章 0 订阅
10 篇文章 0 订阅

The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
Output
For each test case,output the answer on a single line.
Sample Input
3
1 1
10 2
10000 72
Sample Output
1
6
260

枚举 NN 的大于等于 MM 的约数 xx,这样,gcd(N,x)≥Mgcd(N,x)≥M,最后的结果为所有 N/xN/x 的欧拉函数之和。

设 y=N/xy=N/x,欧拉函数是小于 yy 并且与 yy 互质的数的个数,这样 gcd(x∗pi,N)gcd(x∗pi,N) 依然是等于 xx 的,这样就能避免重复计算。

这是他的博客,他的讲解如下,本来我是看懂了的,,,再一看代码。。。给跪了orz,我来替大佬补充
在这里插入图片描述

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
ll T,n,m,res;
ll phi(ll x)
{
	if(x==1)	return 1;
	ll res=x;
	for(ll i=2;i*i<=x;i++)
	{
		if(x%i==0)
		{
			res-=res/i;
			while(x%i==0)	x/=i;
		}
	}
	if(x>1)	res-=res/x;
	return res;
}
int main()
{
	cin>>T;
	while(T--)
	{
		cin>>n>>m;	res=0;
		for(ll i=1;i*i<=n;i++)
		{
			if(n%i)	continue;//只取n的因子,因为其他满足条件的数字可以用
							//n的因子*n的因子的素因子来推出来
							//比如   10   5--1,2,3,4(与5互质的数,欧拉函数)
							//满足条件的是1*2  2*2  3*2 4*2;
			if(i>=m&&i*i!=n)	res+=phi(n/i);
			//&&i*i是因为下一步取得时候会重复
			//因为这个大于等于m且是10的因子的数,那么gcd(10,它*任意一个数)肯定>=m
			//这一步就是取了因子*(10/这个因子)的素因子。。10这个样例的2 4 6 8
			if(n/i>=m)	res+=phi(i);
			//这边跑的是i的素因子*(10/i)
		}
		cout<<res<<endl;
	}
	return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值