Extend to Palindrome

Your task is, given an integer N, to make a palidrome (word that reads the same when you reverse
it) of length at least N. Any palindrome will do. Easy, isn’t it? That’s what you thought before you
passed it on to your inexperienced team-mate. When the contest is almost over, you find out that
that problem still isn’t solved. The problem with the code is that the strings generated are often not
palindromic. There’s not enough time to start again from scratch or to debug his messy code. Seeing
that the situation is desperate, you decide to simply write some additional code that takes the output
and adds just enough extra characters to it to make it a palindrome and hope for the best. Your
solution should take as its input a string and produce the smallest palindrome that can be formed by
adding zero or more characters at its end.

Input

Input will consist of several lines ending in EOF. Each line will contain a non-empty string made up of
upper case and lower case English letters (‘A’-‘Z’ and ‘a’-‘z’). The length of the string will be less than
or equal to 100,000.

Output

For each line of input, output will consist of exactly one line. It should contain the palindrome formed
by adding the fewest number of extra letters to the end of the corresponding input string.

Sample Input
aaaa
abba
amanaplanacanal
xyz

Sample Output
aaaa
abba
amanaplanacanalpanama
xyzyx

思路:将要形成回文的字符串输出,将原串反转后形成的新串与原串相比较,获得原串中与新串相同的字符,输出与原串不同的字符

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <queue>
#include <algorithm>
using namespace std;
const int N=100005;
int F[N];
char a[N],b[N];
void getF (char *P, int m)
{
    F[1]=0;
    for(int i=2;i<=m;i++)
    {
        int k=F[i-1];
        while(k&&P[k+1]!=P[i]) k=F[k];
        if(P[k+1]==P[i]) k++;
        F[i]=k;
    }
}
int findMatch (char *P, int m,char *T, int n)
{
    getF(T,n);
    int k=0;
    for(int i=1;i<=m;i++)
    {
        while(P[i]!=T[k+1]&&k) k=F[k];
        if(P[i]==T[k+1]) k++;
    }
    return k;
}

int main()
{
    while(~scanf("%s",a+1))
    {
        cout<<a+1;
        int al=strlen(a+1);
        for(int i=1;i<=al;i++)
        {
            b[i]=a[i];
        }
        reverse(a+1,a+al+1);
        int temp=findMatch(b,al,a,al);
        for(int i=temp+1;i<=al;i++)
            cout<<a[i];
        cout<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值