Master of Random(数论)

题目描述

Hakase provides Nano with a problem. There is a rooted tree with values on nodes. For each query,you are asked to calculate the sum of the values in the subtree. However, Nano is a rookie so she decides to guess the answer. She has known how the data generator works: it identifi es the nodes with labels from 0 to n-1 and then visits them one by one. For each i (1≤i≤n), the generator selects a node whose label is smaller than i to be its father. The pseudocode is like this:
for i = 1 to n - 1:
father[i] = random(0, i - 1);
where random(a, b) randomly generates a uniformly distributed random integer in range [a, b].
Knowing n and the value of the i-th node ai , Nano decides to randomly choose a subtree and sum up all of the values in the subtree as the answer. Now Hakase wants to know what the expectation of the answer is. Can you help her?

输入

The first line contains an integer T (1≤T≤10) representing the number of test cases.
For each test case, the fi rst line contains an integer n (1≤n≤100000), the number of the nodes in the rooted tree.
The second line contains n integers a0,a1,…,an-1 (1≤ai≤100000) represent the values of nodes.

输出

It can be proven that the answer equals to an irreducible fraction p/q. For each test case, print p*q-1 mod 998244353 in one line. q-1 is the inverse of q under module number 998244353.

样例输入
2
2
1 1
3
1 2 3

样例输出
499122178
166374063

提示
The shape of the tree in the fi rst test case is unique. The father of node 1 is 0. It is possible to choose node 0 or 1 with equal possibility. The sum of the subtree with 0 as the root is 2 while the sum of the subtree with 1 as the root is 1. So the expectation is (2 + 1)/2 = 3/2. The output is 32-1 mod 998244353 = 400122178.
There are two possible shapes in the second test case, node 1’s father destines to be 0, but node 2’s father might be node 0 or node 1. Both conditions are equally possible.
If node 2’s father is node 0, we randomly choose a node. The sum of the subtree with node 0 as the root is 6. The sum of the subtree with node 1 as the root is 2. The sum of the subtree with node 2 as the root is 3.
If node 2’s father is node 1, we randomly choose a node. The sum of the subtree with node 0 as the root is 6. The sum of the subtree with node 1 as the root is 5. The sum of the subtree with node 2 as the root is 3.
So the expectation is (6 + 2 + 3 + 6 + 5 + 3)/6 = 25/6. The output is 25
6-1 mod 998244353 = 166374063.

思路
由题可推得每个点出现的次数为(n-1)!/i,所以该题数学期望为每个点的出现次数*每个点的权值的总和除以n!

代码实现

#include<bits/stdc++.h>
using namespace std;
const int mod=998244353;
typedef long long ll;
ll quickmod(ll a,ll b)  // 快速幂
{
    ll ans=1;
    while(b)
    {
        if(b&1) ans=ans*a%mod;
        a=a*a%mod;
        b>>=1;
    }
    return ans;
}
ll inv(ll x) //  乘法逆元
{
    return quickmod(x,mod-2);
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        ll lx=1;
        for(int i=2;i<n;i++) lx=lx*i%mod; // 求(n-1)!
        ll t,lxx=lx;
        scanf("%lld",&t);
        ll ans=lx*t%mod; //1号节点贡献
        for(int i=1;i<n;i++)
        {
            scanf("%lld",&t);
            lxx=lxx+lx*inv(i)%mod; 
            ans=(ans+lxx*t)%mod; //+i号节点贡献
        }
        lx=lx*n%mod; // 求n!
        printf("%lld\n",ans*inv(lx)%mod); //输出数学期望
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值