PAT 1040 Longest Symmetric String

PAT 1040 Longest Symmetric String(最长回文子串)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:
Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:
For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

思路:
1.dp[i][j]表示s[i]至s[j]所表示的子串是否是回文子串,1表示是,0表示否
2.i表示字串的长度,如果s[j]==s[k],只要s[j+1][k-1]是回文字符串,那么s[j]到s[k]也就是,如果不是,则也不是。
3.弱国s[j]!=s[k],那么肯定不是回文子串
4.这一题遍历长度比较合适,但不是最优解法,还有更好的解法继续加油!

代码:

#include<bits/stdc++.h>
using namespace std;
int dp[1005][1005]={0};
main(){
	string s;
	getline(cin,s);
	int len=s.length();
	int ans=1;
	for(int i=0;i<len;i++){
		dp[i][i]=1;
	}
	for(int i=0;i<len;i++){
		if(i<len-1){
			if(s[i]==s[i+1]){
				dp[i][i+1]=1;
				ans=2;
			}
		}
	}
	for(int i=3;i<=len;i++){
		for(int j=0;j+i-1<len;j++){
			int k=j+i-1;
			if(s[j]==s[k]&&dp[j+1][k-1]==1){
				dp[j][k]=1;
				ans=i;
			}
		}
	}
	cout<<ans<<endl;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值