1072 Gas Station (30 分)

1072 Gas Station (30 分)

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (<= 103), the total number of houses; M (<= 10), the total number of the candidate locations for the gas stations; K (<= 104), the number of roads connecting the houses and the gas stations; and DS, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format
P1 P2 Dist
where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output “No Solution”.

Sample Input 1:

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1:

G1
2.0 3.3

Sample Input 2:

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2:

No Solution

题目大意:给定一个图,有加油站和居民区,其中加油站的结点名前有G,在不超过服务范围的情况下,从加油站中选取一个站点使其到最近的居民区最远,如果有多个这样的加油站则输出平均距离最近的,如果还是相等则输出序号最小的
分析:G开头的加油站编号在n之后m位,因为加油站之间彼此有连接,因此Dijkstra算法的范围在1~n+m之间。

#include<cstring>
#include<vector>
#include<cmath>
#include<iostream>
#include<string>
using namespace std;
const int maxn = 1050;
const int INF = (1 << 30) - 1;
int n, m, k, ds;
int G[maxn][maxn] = { 0 }, d[maxn];
bool vis[maxn] = { false };
void Dijkstra(int s) {
	fill(d, d + maxn, INF);
	memset(vis, false, sizeof(vis));
	d[s] = 0;
	for (int i = 1;i <= n + m;++i) {
		int u = -1, MIN = INF;
		for (int j = 1;j <= n + m;++j) {
			if (vis[j] == false && d[j] < MIN) {
				u = j;
				MIN = d[j];
			}
		}
		if (u == -1) return;
		vis[u] = true;
		for (int v = 1;v <= n + m;++v) {
			if (vis[v] == false && G[u][v] != 0) {
				if (d[u] + G[u][v] < d[v]) {
					d[v] = d[u] + G[u][v];
				}
			}
		}
	}
}
int main() {
	scanf("%d %d %d %d", &n, &m, &k, &ds);
	for (int i = 0;i < k;++i) {
		string str1, str2;
		int u, v, dis;
		cin >> str1 >> str2 >> dis;
		if (str1[0] == 'G') {
			str1.erase(str1.begin());
			u = stoi(str1) + n;
		}
		else u = stoi(str1);
		if (str2[0] == 'G') {
			str2.erase(str2.begin());
			v = stoi(str2) + n;
		}
		else v = stoi(str2);
		G[u][v] = G[v][u] = dis;
	}
	int ansdis = 0, ansid = -1;
	double ansave;
	for (int i = n + 1;i <= n + m;++i) {
		bool flag = true;//是否满足所有点都在范围 
		Dijkstra(i);
		int mindis = INF, sum = 0;
		for (int j = 1;j <= n;++j) {
			if (d[j] > ds) {
				flag = false;
				break;
			}
			if (d[j] < mindis) {
				mindis = d[j];
			}
			sum += d[j];
		}
		if (flag == false) continue;
		double tempAve = 1.0 * sum / n;
		if (mindis > ansdis) {
			ansdis = mindis;
			ansid = i;
			ansave = tempAve;
		}
		else if (mindis == ansdis && tempAve < ansave) {
			ansave = tempAve;
			ansid = i;
		}
	}
	if (ansid != -1) {
		cout << "G" << ansid - n << endl;
		printf("%.1f %.1f", (double)ansdis, round(ansave * 10) / 10);
	}
	else printf("No Solution");
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
c++解决pipeline system consists of N transfer station, some of which are connected by pipelines. For each of M pipelines the numbers of stations A[i] and B[i], which are connected by this pipeline, and its profitability C[i] are known. A profitability of a pipeline is an amount of dollars, which will be daily yielded in taxes by transferring the gas through this pipeline. Each two stations are connected by not more than one pipeline. The system was built by Soviet engineers, who knew exactly, that the gas was transferred from Ukrainian gas fields to Siberia and not the reverse. That is why the pipelines are unidirectional, i.e. each pipeline allows gas transfer from the station number A[i] to the station number B[i] only. More over, if it is possible to transfer the gas from the station X to the station Y (perhaps, through some intermediate stations), then the reverse transfer from Y to X is impossible. It is known that the gas arrives to the starting station number S and should be dispatched to the buyers on the final station number F. The President ordered the Government to find a route (i.e. a linear sequence of stations which are connected by pipelines) to transfer the gas from the starting to the final station. A profitability of this route should be maximal. A profitability of a route is a total profitability of its pipelines. Unfortunately, the President did not consider that some pipelines ceased to exist long ago, and, as a result, the gas transfer between the starting and the final stations may appear to be impossible... Input The first line contains the integer numbers N (2 ≤ N ≤ 500) and M (0 ≤ M ≤ 124750). Each of the next M lines contains the integer numbers A[i], B[i] (1 ≤ A[i], B[i] ≤ N) and C[i] (1 ≤ C[i] ≤ 10000) for the corresponding pipeline. The last line contains the integer numbers S and F (1 ≤ S, F ≤ N; S ≠ F). Output If the desired route exists, you should output its profitability. Otherwise you should output "No solution".
05-28

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值