1075 PAT Judge (25分)列出了3个个人以为难点

1075 PAT Judge (25分)

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10
​4
​​ ), the total number of users, K (≤5), the total number of problems, and M (≤10
​5
​​ ), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:
For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] … s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:
7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:
1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

我认为有以下3个难点

难点1:

对于0,-1,>0 这3部分数据的处理:
分数为0或-1(实际上得分为0)暂时设置为-2 (最后输出0)
因此0的位置就保存了默认的没有被赋过值的0,也就是这门科目没有参加 (最后输出-)
其他>0的数不变 (输出>0)

难点2:

对于输入重复数据的处理,有以下三种情况:
1.先输入>0的数,再输入0或-1
2.先输入0或-1,再输入>0的数
3.先输入>0,在输入>0
情况1:可以对输入为0或-1时再&&一个条件(保证原来的数没有出现||原来的数出现了但是为-2)
情况2:因为我们把0保存在了-2,所以可以直接对后来出现>0的数直接与原来的数比较大小
情况3:比较大小,更新max_mark

难点3:

计算一个考生满分题目个数的时候,考虑到考生可能提交多次满分的情况下,需要设立bool pass[6]={false}来去重。

#include<iostream>
#include<algorithm>
#include<map>
#include<vector>
using namespace std;
int n,k,m;
struct node{
    int id,total_num=0,pass_num=0;
    int score[6]={0},pass[6]={false};
};
bool cmp(node a,node b){
    if(a.total_num!=b.total_num) return a.total_num>b.total_num;
    return a.pass_num!=b.pass_num?a.pass_num>b.pass_num:a.id<b.id;
}
int main(){
    cin>>n>>k>>m;
    vector<node> data(n+1),ans;
    vector<int> full_marks(k+1),have(n+1,false);
    for(int i=1;i<=k;i++) cin>>full_marks[i];
    for(int i=0;i<m;i++){
        int id,No,score;
        cin>>id>>No>>score;
        if(score!=-1) have[id]=true;
        data[id].id=id;
        if((score==-1||score==0)&&(data[id].score[No]==0||data[id].score[No]==-2)) 
            data[id].score[No]=-2;
        else if(score>data[id].score[No])
            data[id].score[No]=score;
    }
    for(int i=1;i<=n;i++){
        for(int j=1;j<=k;j++){
            int temp;
            if(data[i].score[j]==-2) temp=0;
            else temp=data[i].score[j];
            if(temp==full_marks[j]&&!data[i].pass[j]) {
                data[i].pass_num++;
                data[i].pass[j]=true;
            }
            data[i].total_num+=temp;
        }
        if(have[i])
            ans.push_back(data[i]);
    }
    sort(ans.begin(),ans.end(),cmp);
    int pre=1,now;
    for(int i=0;i<ans.size();i++){
        if(i>0&&ans[i].total_num==ans[i-1].total_num)
            now=pre;
        else{
            now=i+1;
            pre=i+1;
        }
        printf("%d %05d %d",now,ans[i].id,ans[i].total_num);
        for(int j=1;j<=k;j++){
            if(ans[i].score[j]==0) printf(" -");
            else if(ans[i].score[j]==-2) printf(" 0");
            else printf(" %d",ans[i].score[j]);
        }
        printf("\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值