Constructing Roads(HDU 1102)---已确定边的最小生成树(Kruskal算法)

题目链接

题目描述

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.
We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

输入格式

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.
Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

输出格式

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

输入样例

3
0 990 692
990 0 179
692 179 0
1
1 2

输出样例

179

分析

题目大意是给定n个点的无向图,求图的最小生成树,其中有些边已经确定(Ps:可能是最小生成树的一部分,也可能不是)。
对于这道题,由于已经确定了部分边,所以只能用Kruskal算法,而不能用prim算法。在读入"确定边"过程中,如果两点还未合并连接在一起,就更新边数k=k+1,以下是用堆优化的Kruskal算法具体源码:

源程序

Kruskal算法

#include <bits/stdc++.h>
#define MAXN 105
using namespace std;
struct Edge{
	int u,v,w;
	bool operator <(const Edge a)const{
		return w>a.w;
	} 
};
int n,m,k,father[MAXN];
priority_queue<Edge> q;
void init()
{
	while(!q.empty())q.pop();	
	for(int i=1;i<=n;i++)father[i]=i;
	k=0;
}
int find(int x)	//并查集 
{
	if(x==father[x])return x;
	return father[x]=find(father[x]);
}
bool Union(int x,int y)	//合并 
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy){
		father[fx]=fy;
		return true;
	} 
	return false;
}
int kruskal()
{
	int ans=0;
	while(k<n-1){
		int u=q.top().u,v=q.top().v,w=q.top().w;
		q.pop();	
		if(Union(u,v)){		//如果两点还未合并
			ans+=w;	//更新权值 
			k++; 	//更新边数 
		}
	}	
	return ans; 
} 
int main()
{
	while(~scanf("%d",&n)){
		init();	//初始化 
		for(int i=1;i<=n;i++)	//处理图 
			for(int j=1;j<=n;j++){
				int w;
				scanf("%d",&w);
				q.push(Edge{i,j,w});	//入栈 
			}
		scanf("%d",&m); 
		for(int i=1;i<=m;i++){	//已确定的边 
			int u,v;
			scanf("%d%d",&u,&v);
			if(Union(u,v))	//如果这两点还未合并,生成树边数+1 
				k++;	
		}
		printf("%d\n",kruskal());
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值