Connect the Cities(HDU 3371)---局部连通的最小生成树

题目链接

题目描述

In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.

输入格式

The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.

输出格式

For each case, output the least money you need to take, if it’s impossible, just output -1.

输入样例

1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6

输出样例

1

分析

题目大意是给定n个点和m条边的无向图,求该图的最小生成树,其中已经确定了k个连通块。
对于这道题,对于k个连通块先用并查集合并,然后直接套用Kruskal模板即可

源程序

Kruskal算法

#include <bits/stdc++.h>
#define MAXN 505
#define MAXM 25005
using namespace std;
struct Edge{
	int u,v,w;
	bool operator <(const Edge a)const{
		return w<a.w;
	}
}edge[MAXM];
int t,n,m,k,father[MAXN];
int find(int x)
{
	if(x==father[x])return x;
	return father[x]=find(father[x]);
}
bool Union(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy){
		father[fx]=fy;
		return true;
	}
	return false;
}
int main()
{
	scanf("%d",&t);
	while(t--){
		scanf("%d%d%d",&n,&m,&k);
		for(int i=1;i<=n;i++)	//初始化
			father[i]=i; 
		for(int i=1;i<=m;i++)
			scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
		sort(edge+1,edge+m+1);
		int ans=0,cnt=0;	//生成树的权值和边数 
		for(int i=1;i<=k;i++){		//连接已有的边 
			int p,u,v;	//点数
			scanf("%d%d",&p,&u);
			for(int j=2;j<=p;j++){
				scanf("%d",&v);
				if(Union(u,v))	//如果还没合并
					cnt++; 
			}
		}
		for(int i=1;i<=m&&cnt<n-1;i++){
			int u=edge[i].u,v=edge[i].v,w=edge[i].w;
			if(Union(u,v)){	//如果还没合并,就更新边数和权值 
				cnt++;
				ans+=w; 
			}
		}
		if(cnt==n-1)
			printf("%d\n",ans); 
		else 
			printf("-1\n");
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值