Selecting Courses(POJ 2239)---二分图最大匹配

题目链接

题目描述

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall.
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible.

输入格式

The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1…M), and no stall will be listed twice for a given cow.
Output

输出格式

For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

输入样例

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2

输出样例

4

分析

题目大意是给定n个课程,每个课程可能在第p天的第q节课开课,求一个人选修课程的最大数目,即课程的最大匹配数。
这里我们将开课时间分别编号为301~384(一天12节课,共7天),考虑到点集大小,故将时间作为左点集,课程作为右点集进行求最大匹配,套用匈牙利算法模板即可,以下分别是dfs和bfs版本的源代码。

源程序

DFS版本

#include <iostream>
#include <cstdio>
#include <cstring>
#define MAXN 405
#define MAXM MAXN*100
using namespace std;
struct Edge{
	int u,v,next;
	Edge(){}
	Edge(int u,int v,int next):u(u),v(v),next(next){}
}edge[MAXM];
int EdgeCount,head[MAXN];
int n,m,link[MAXN];
bool vis[MAXN];
void addEdge(int u,int v)
{
	edge[++EdgeCount]=Edge(u,v,head[u]);
	head[u]=EdgeCount;
}
bool dfs(int u)
{
	for(int i=head[u];i;i=edge[i].next){
		int v=edge[i].v;
		if(!vis[v]){	//不在交替路中
			vis[v]=true;
			if(link[v]==-1 || dfs(link[v])){	//未匹配点或者找到新方案
				link[v]=u;
				return true; 
			} 
		}
	}
	return false;
}
int hargarian()
{
	memset(link,-1,sizeof(link));
	int ans=0;	//记录匹配数
	for(int i=301;i<=384;i++){	//寻找方案匹配 
		memset(vis,false,sizeof(vis));
		if(dfs(i))
			ans++; 
	} 
	return ans;
}
int main()
{
	while(~scanf("%d",&n)){
		memset(head,0,sizeof(head));	//初始化 
		EdgeCount=0;
		for(int u=1;u<=n;u++){	//建图 
			scanf("%d",&m);
			for(int i=1;i<=m;i++){
				int p,q,v;
				scanf("%d%d",&p,&q);
				addEdge(300+(p-1)*12+q,u);	//时间的编号为301~384
			} 								//且时间为左点集,课程为右点集 
		}
		printf("%d\n",hargarian()); 
	}
}

BFS版本

#include <cstdio>
#include <cstring>
#include <iostream>
#include <queue>
#define MAXN 405
#define MAXM MAXN*100
using namespace std;
struct Edge{
	int u,v,next;
	Edge(){}
	Edge(int u,int v,int next):u(u),v(v),next(next){}
}edge[MAXM];
int EdgeCount,head[MAXN];
int n,m,day,tim,pre[MAXN],vis[MAXN],link[MAXN];
queue<int> q; 
void addEdge(int u,int v)
{
	edge[++EdgeCount]=Edge(u,v,head[u]);
	head[u]=EdgeCount;
}
int hargarian()
{
	memset(pre,-1,sizeof(pre));
	memset(vis,-1,sizeof(vis));
	memset(link,-1,sizeof(link));
	int ans=0;	//记录匹配数
	for(int i=301;i<=384;i++){
		if(link[i]==-1){	//尚未匹配
			while(!q.empty()) q.pop();	//清空队列 
			q.push(i);
			bool flag=false;
			while(!q.empty()&&!flag){	//寻找匹配方案
				int u=q.front();q.pop();
				for(int j=head[u];j;j=edge[j].next){
					if(flag) break;	//已找到匹配方案
					int v=edge[j].v;
					if(vis[v]!=i){	//不在交替路中
						vis[v]=i;
						if(link[v]>=0)	//对应点已有匹配,寻找新方案
							q.push(link[v]),pre[link[v]]=u;
						else{	//找到匹配点 
							flag=true;	 
							int l=u,r=v;
							while(l!=-1){	//分配方案 
								int tmp=link[l];
								link[l]=r;
								link[r]=l;
								l=pre[l];
								r=tmp; 
							} 
						} 
					} 
				}
			}
			if(link[i]!=-1)	//该点有匹配点
				ans++; 
		}
	} 
	return ans;
}
int main()
{
	while(~scanf("%d",&n)){
		memset(head,0,sizeof(head));	//初始化 
		EdgeCount=0;
		for(int u=1;u<=n;u++){	//建边 
			scanf("%d",&m);
			for(int i=1;i<=m;i++){	
				scanf("%d%d",&day,&tim);
				addEdge(300+(day-1)*12+tim,u);	//时间的编号为301~384
			} 								//且时间为左点集,课程为右点集
		} 
		printf("%d\n",hargarian()); 
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值