HDU - 2577-How to Type

Problem Description

Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.

Input

The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.

Output

For each test case, you must output the smallest times of typing the key to finish typing this string.

Sample Input

3
Pirates
HDUacm
HDUACM

Sample Output

8
8
8

Hint

The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.
The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8
The string “HDUACM”, can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

#include <iostream> 
#include <string> 
#include <cstring> 
using namespace std;

int keda(char a)
{
	if (a <= 90)return 1;
	else return 0;
}
int main()
{
	
	int t;
	cin >> t;
	while (t--)
	{
		char a[105];
		cin >> a;
		int s = strlen(a), k = 0,j;
		for (int i = 0; i < strlen(a); i++)
		{
			int t = keda(a[i]);
			for (j = i + 1; j < strlen(a); j++) 
			{
				if (t != keda(a[j]))break;
			}
			if (t == 1 && k == 0 && j - i < 2)
				s++;
			else if (t == 1 && k == 0 && j - i >= 2)
			{
				s++, k = 1;
			}
			else if (t == 0 && k == 1 && j - i < 2 && j == strlen(a))
			{
				s++, k = 0;
			}
			else if (t == 0 && k == 1 && j - i < 2)
			{
				s++;
			}
			else if (t == 0 && k == 1 && j - i >= 2)
			{
				s++, k = 0;
			}
			i = j - 1;
		}
		if (k==1)s++;
		cout << s << endl;
	}
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

wujiekd

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值