HDU - 1078 FatMouse and Cheese (DFS+DP)

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.
The input ends with a pair of -1’s.
Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
Sample Input
3 1
1 2 5
10 11 6
12 12 7
-1 -1
Sample Output
37
问题链接http://acm.hdu.edu.cn/showproblem.php?pid=1078
问题简述:给定地图边界(n×n),老鼠从(0,0)的起点开始跳跃。能跳跃1到k个格子。并且只能往奶酪数多的格子走,问最多能吃多少个奶酪
问题分析:dfs+dp,用DP数组来获取每个格子所能得到的最多奶酪数,从每个不能再跳跃的格子往前DP,并且通过记忆化搜索,当DP[x][y]有值时直接返回DP[x][y]。核心:
if(dp[x][y]) return dp[x][y];
int t=dfs(X,Y);
maxn=max(maxn,t);
dp[x][y]=maxn+mapb[x][y];
代码附注释
AC通过的C++语言程序如下:

#include <iostream>
#include <algorithm>
#include <iostream>
#include <string>
#include <stdio.h>
#include <algorithm>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <math.h>
#include <climits>
#include <iomanip>
#include <queue>
#include<vector>
using namespace std;

const int N=1005;
int mapb[N][N];//地图
int dp[N][N];//记录每个格子所能获得的最多奶酪数
int dir[4][2]={0,1,0,-1,1,0,-1,0};//方向向量
int n,k;//迷宫大小以及能跳的格子数

bool checkedge(int x,int y)//检查是否跳出地图
{
    if(x>=0&&y>=0&&x<n&&y<n)
        return 1;
    return 0;
}

int dfs(int x,int y)
{
    if(dp[x][y]) return dp[x][y];//如果dp的这个格子有值,直接返回这个值(记忆化)
    int maxn=0;//记录在(x,y)的格子前能获得的最多奶酪
    for(int i=0;i<4;i++)//四个方向
    {
        for(int j=1;j<=k;j++)//向那个方向跳多少格
        {
            int X=x+j*dir[i][0];//跳跃后的x
            int Y=y+j*dir[i][1];//跳跃后的y
            if(mapb[X][Y]>mapb[x][y]&&checkedge(X,Y))//该格子比原格子的奶酪多并且没有跳出地图
            {
                int t=dfs(X,Y);//记录跳跃后能得到的最多奶酪值
                maxn=max(maxn,t);//比较跳跃后跟不跳跃的奶酪,取大值
            }
        }
    }
    dp[x][y]=maxn+mapb[x][y];//当前在格子能获得的最大奶酪等于跳跃前获得的最大奶酪加上该格子的奶酪
    return dp[x][y];//返回该格子的最大值
}

int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n>>k)
    {
        if(n==-1&&k==-1)
            break;
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)//输入地图
                cin>>mapb[i][j];
        cout<<dfs(0,0)<<endl;//输出在(0,0)点能获得的最大奶酪
        memset(dp,0,sizeof(dp));//初始化
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值